vmware: deprecate ESX driver

Bug #1291194 reported by Subbu on 2014-03-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Medium
Vipin Balachandran

Bug Description

VMware has decided to deprecate the ESX driver both in Nova and Cinder. The idea is to focus on the VC driver since that gives much more direct value to users.

ESX Nova driver is already deprecated for IceHouse - https://review.openstack.org/#/c/79060/

The ESX Cinder driver also needs to be marked deprecated for IceHouse and removed in Juno.

Changed in cinder:
importance: Undecided → Medium
milestone: none → icehouse-rc1
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/79893

Changed in cinder:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/79893
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=0fc3afdff1a2b87589206ffb22b041d58fe0f99b
Submitter: Jenkins
Branch: master

commit 0fc3afdff1a2b87589206ffb22b041d58fe0f99b
Author: Vipin Balachandran <email address hidden>
Date: Tue Mar 11 05:51:03 2014 +0530

    vmware: Mark VMware ESX vmdk driver as deprecated

    The VMware ESX driver in Nova is now marked as deprecated and will be
    removed in Juno release. This change marks the VMware ESX vmdk driver
    as deprecated since it is intended for use with the ESX driver in Nova.
    The plan is to remove the ESX vmdk driver in Juno release.

    Closes-Bug: #1291194
    DocImpact
    Change-Id: I285f3461c1ccef56329b70417fb023405dfceb5e

Changed in cinder:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2014-03-27
Changed in cinder:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-04-17
Changed in cinder:
milestone: icehouse-rc1 → 2014.1
Robert Esker (esker) wrote :

Given the manner that the vCenter driver subverts much of the utility of Cinder's various integrations, it's extremely surprising that this was allowed to proceed. The vCenter driver breaks the model (although I can certainly understand why VMware would attempt to do this)... just surprised it was caught for what it is.

Robert Esker (esker) wrote :

Last sentence should read : "... just surprised it wasn't caught for what is "

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers