3PAR terminate connection fails during VM live migration

Bug #1288927 reported by Walt Boring on 2014-03-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Cinder
Critical
Walt Boring

Bug Description

The 3PAR driver assumes there will only be 1 volume attached to a single host at any time. From the cinder perspective this is always true as multi attach is NOT supported currently in cinder. During nova vm live migration, nova bypasses cinder's checks to a volume being already attached and asks cinder to attach the same volume to another host. Then nova asks cinder to detach the volume from the original vm host. This fails for 3PAR because the driver doesn't look for a VLUN on a host. It assumes there is 1 volume on 1 host always.

The 3par drivers fail at detach time saying it can't find the VLUN on the existing host.

tags: added: drivers
Changed in cinder:
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/78722

Changed in cinder:
status: Confirmed → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/78736

Reviewed: https://review.openstack.org/78736
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=2c1701e2f50feb5fa25ea6fb1b620f39346779de
Submitter: Jenkins
Branch: master

commit 2c1701e2f50feb5fa25ea6fb1b620f39346779de
Author: Walter A. Boring IV <email address hidden>
Date: Thu Mar 6 11:52:33 2014 -0800

    Fixed nova VM live migration issue with 3PAR

    Nova bypasses the cinder checks for a volume
    being available, when it tries to attach a volume
    to a new host during live migration. The assumption
    in cinder to this point has been that volumes can only
    be attached to one host. The 3PAR driver worked under
    that assumption. This assumption fell apart during detach
    time as the driver was only looking for a VLUN on the
    entire 3PAR, since it assumed it could only exist on one host.

    This patch ensures that the driver looks for the VLUN on the
    hostname it expects.

    Change-Id: Ie894ad386990794d270ca1cb72f40095bd40c2e6
    Closes-Bug: 1288927

Changed in cinder:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2014-03-27
Changed in cinder:
status: Fix Committed → Fix Released
tags: added: havana-backport-potential
Thierry Carrez (ttx) on 2014-04-17
Changed in cinder:
milestone: icehouse-rc1 → 2014.1

Change abandoned by Alan Pevec (<email address hidden>) on branch: stable/havana
Review: https://review.openstack.org/84152
Reason: Final Havana release 2013.2.4 has been cut and stable/havana is going to be removed in a week.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers