3par: Delete (missing) snapshot stuck in error deleting

Bug #1283233 reported by Ramy Asselin on 2014-02-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Low
Ramy Asselin

Bug Description

Steps to reproduce:
1. Create a snapshot.
2. Manually delete it from 3PAR outside of cider
3. Delete the snapshot from cinder.

Result: Snapshot stuck in error deleting state

Expected Result: Snapshot removed from cinder.

Changed in cinder:
assignee: nobody → Ramy Asselin (ramy-asselin)
status: New → In Progress

Reviewed: https://review.openstack.org/75982
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=e31b9e78374bcaeae573cce2915897ceb870ffc3
Submitter: Jenkins
Branch: master

commit e31b9e78374bcaeae573cce2915897ceb870ffc3
Author: Ramy Asselin <email address hidden>
Date: Mon Feb 24 12:29:01 2014 -0800

    3PAR: Delete missing snapshot stuck in error_del

    If the snapshot is deleted outside of cinder, attempting
    to delete it again results in the snapshot state stuck in
    error_deleting.

    This is because the current code raises a NotFound exception,
    but the base cinder code does not catch this and update its db.

    Instead, log a warning, and simply tell the base cinder code that it was
    successfully deleted.

    Change-Id: I5c5d24bc113e320346ff4f1f4f62fffdf7cddfc4
    Closes-Bug: #1283233

Changed in cinder:
status: In Progress → Fix Committed
Changed in cinder:
milestone: none → icehouse-3
Thierry Carrez (ttx) on 2014-03-05
Changed in cinder:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-04-17
Changed in cinder:
milestone: icehouse-3 → 2014.1
Changed in cinder:
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers