c-vol error: logical volume already exists in volume group

Bug #1271664 reported by Mark McLoughlin on 2014-01-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Medium
John Griffith

Bug Description

Example logstash search:

  message:"already exists in volume group" AND filename:"console.html"

I hit it here:

  http://logs.openstack.org/40/68040/2/check/check-grenade-dsvm/4ec446d/console.html
  http://logs.openstack.org/40/68040/2/check/check-grenade-dsvm/4ec446d/logs/new/screen-c-vol.txt.gz?level=ERROR
     sudo cinder-rootwrap /etc/cinder/rootwrap.conf lvcreate -n volume-bebcbca0-8bba-4edc-aac3-4c32c6470796 stack-volumes -L 1g
     Logical volume "volume-bebcbca0-8bba-4edc-aac3-4c32c6470796" already exists in volume group "stack-volumes"

Related to this?

  http://logs.openstack.org/40/68040/2/check/check-grenade-dsvm/4ec446d/logs/new/screen-c-sch.txt.gz?level=ERROR

    line 255, in update_iscsi_target\n raise exception.ISCSITargetUpdateFailed(name=name)\n', u'ISCSITargetUpdateFailed: An unknown exception occurred.\n'

Somewhat similar signature to bug #1223469 but that's apparently long resolved

Joe Gordon (jogo) wrote :

logstash query:

message:"already exists in volume group" AND message:"sudo cinder-rootwrap /etc/cinder/rootwrap.conf lvcreate -n " AND filename:"console.html"

Changed in cinder:
status: New → Confirmed
John Griffith (john-griffith) wrote :

Grrr.... we wiped one instance of this out previously.

So what I believe is happening here is that the create is failing for an issue that's not in task-flows blacklist so we retry it, the trouble is that the lvcreate was succesful so the subsequent calls aren't all that smart, they try the whole deal again including the lvcreate an boom... you get this mess.

Changed in cinder:
importance: Undecided → Medium
assignee: nobody → John Griffith (john-griffith)
John Griffith (john-griffith) wrote :

Yup, that's the end result, however the root cause is bit nastier. I think another related side effect of some refactoring that's been going on around tgt-update.

John Griffith (john-griffith) wrote :

BTW I just submitted another fix for:
bug #1223469 as it was broken by a refactor change earlier this month.

Joe Gordon (jogo) wrote :

This hasn't been seen in the gate in two weeks, marking as resolved

Changed in cinder:
status: Confirmed → Fix Committed
Thierry Carrez (ttx) on 2014-03-05
Changed in cinder:
milestone: none → icehouse-3
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-04-17
Changed in cinder:
milestone: icehouse-3 → 2014.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers