Bump hacking to 0.8

Bug #1257274 reported by Sergio Cazzolato on 2013-12-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Undecided
Avishay Traeger

Bug Description

Due to Bump hacking dependency is not the 0.8, some compatibility checks with python 3.x are not being done on gate and it is bringing code issues.

Changed in cinder:
assignee: nobody → Sergio Cazzolato (sergio-j-cazzolato)

Fix proposed to branch: master
Review: https://review.openstack.org/59704

Changed in cinder:
status: New → In Progress
Changed in cinder:
assignee: Sergio Cazzolato (sergio-j-cazzolato) → Avishay Traeger (avishay-il)
affects: cinder → glance
affects: glance → cinder

Reviewed: https://review.openstack.org/59643
Committed: http://github.com/openstack/cinder/commit/aa453576ff13c97c63dcb3cd5941675ffdc93360
Submitter: Jenkins
Branch: master

commit aa453576ff13c97c63dcb3cd5941675ffdc93360
Author: Avishay Traeger <email address hidden>
Date: Tue Dec 3 09:44:35 2013 +0200

    Update hacking to hacking>=0.8.0,<0.9

    Update hacking version to match version specified in requirements repo.

    Fixed the following issues, which the newer version checks for:
    print "" -> print("")
    self.assertEquals -> self.assertEqual
    self.assertNotEquals -> self.assertNotEqual

    Change-Id: Ic4b70fd8f565cda28e23fe6b1da0e278f949373c
    Closes-Bug: #1256738
    Closes-Bug: #1256737
    Closes-Bug: #1257274

Changed in cinder:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2014-01-22
Changed in cinder:
milestone: none → icehouse-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-04-17
Changed in cinder:
milestone: icehouse-2 → 2014.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers