NetApp cinder driver reports 0 free space for the first 60 seconds

Bug #1253660 reported by Ben Swartzlander on 2013-11-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Medium
Navneet
Havana
Undecided
Unassigned

Bug Description

The NetApp driver (in clustered mode) collects free space in an asynchronous background job, which results in the free space being reported as 0 until the job has run at least once (takes 60 seconds). The driver should be changed to report the correct free space immediately upon starting up.

tags: added: cmode netapp
summary: - NetApp cinder driver report 0 free space for the first 60 seconds
+ NetApp cinder driver reports 0 free space for the first 60 seconds
Navneet (singn) on 2013-11-22
Changed in cinder:
assignee: nobody → Navneet (singn)
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/57898

Changed in cinder:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/57898
Committed: http://github.com/openstack/cinder/commit/585f34ff7798ad271121d432e0cae8820bc54389
Submitter: Jenkins
Branch: master

commit 585f34ff7798ad271121d432e0cae8820bc54389
Author: Navneet Singh <email address hidden>
Date: Mon Nov 18 02:38:07 2013 +0530

    NetApp fix free space as zero during 1st vol stats update

    NetApp clustered ontap drivers report space as zero
    till first 60 seconds of driver start. This is causing
    discomfort for some performance sensitive deployements.
    This was due to async nature of the NetApp stats collection job.
    Job is changed to sync at driver start to improve customer
    experience.

    Change-Id: I7d5cbf590897a0d328ece3a60516c92c0ad0ee7f
    Closes-bug: #1253660

Changed in cinder:
status: In Progress → Fix Committed
Navneet (singn) on 2013-11-25
tags: added: havana-backport-potential
Huang Zhiteng (zhiteng-huang) wrote :

Maybe also backport the fix to Grizzly?

Navneet (singn) wrote :

No, its only eligible for Havana as we made the relevant changes in Havana.

Changed in cinder:
importance: Undecided → Medium
milestone: none → icehouse-1
Thierry Carrez (ttx) on 2013-12-04
Changed in cinder:
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/58193
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=c07d60fe456484b45cff543cfd08391b0e3ba9f2
Submitter: Jenkins
Branch: stable/havana

commit c07d60fe456484b45cff543cfd08391b0e3ba9f2
Author: Navneet Singh <email address hidden>
Date: Mon Nov 18 02:38:07 2013 +0530

    NetApp fix free space as zero during 1st vol stats update

    NetApp clustered ontap drivers report space as zero
    till first 60 seconds of driver start. This is causing
    discomfort for some performance sensitive deployements.
    This was due to async nature of the NetApp stats collection job.
    Job is changed to sync at driver start to improve customer
    experience.

    Change-Id: I7d5cbf590897a0d328ece3a60516c92c0ad0ee7f
    Closes-bug: #1253660
    (cherry picked from commit 585f34ff7798ad271121d432e0cae8820bc54389)

tags: added: in-stable-havana
Thierry Carrez (ttx) on 2014-04-17
Changed in cinder:
milestone: icehouse-1 → 2014.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers