VMware: upload-to-image failure

Bug #1237338 reported by Subbu on 2013-10-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
High
Subbu
Havana
High
Eric Harney
VMwareAPI-Team
High
Unassigned

Bug Description

upload-to-image always fails with this trace.

2013-10-09 02:23:12.432 5475 ERROR cinder.volume.drivers.vmware.vmdk [req-268d75a3-5d8d-4556-a7ba-b985e32246e1 fb148ba9526647fe8fb2d59ed31f7209 17da75a3ea634b458952aa8492c968a8] Upload to glance of volume not supported in state: uploading.
2013-10-09 02:23:12.532 5475 ERROR cinder.openstack.common.rpc.amqp [req-268d75a3-5d8d-4556-a7ba-b985e32246e1 fb148ba9526647fe8fb2d59ed31f7209 17da75a3ea634b458952aa8492c968a8] Exception during message handling
2013-10-09 02:23:12.532 5475 TRACE cinder.openstack.common.rpc.amqp Traceback (most recent call last):
2013-10-09 02:23:12.532 5475 TRACE cinder.openstack.common.rpc.amqp File "/root/work/cinder3/cinder/cinder/openstack/common/rpc/amqp.py", line 441, in _process_data
2013-10-09 02:23:12.532 5475 TRACE cinder.openstack.common.rpc.amqp **args)
2013-10-09 02:23:12.532 5475 TRACE cinder.openstack.common.rpc.amqp File "/root/work/cinder3/cinder/cinder/openstack/common/rpc/dispatcher.py", line 148, in dispatch
2013-10-09 02:23:12.532 5475 TRACE cinder.openstack.common.rpc.amqp return getattr(proxyobj, method)(ctxt, **kwargs)
2013-10-09 02:23:12.532 5475 TRACE cinder.openstack.common.rpc.amqp File "/root/work/cinder3/cinder/cinder/utils.py", line 808, in wrapper
2013-10-09 02:23:12.532 5475 TRACE cinder.openstack.common.rpc.amqp return func(self, *args, **kwargs)
2013-10-09 02:23:12.532 5475 TRACE cinder.openstack.common.rpc.amqp File "/root/work/cinder3/cinder/cinder/volume/manager.py", line 555, in copy_volume_to_image
2013-10-09 02:23:12.532 5475 TRACE cinder.openstack.common.rpc.amqp payload['message'] = unicode(error)
2013-10-09 02:23:12.532 5475 TRACE cinder.openstack.common.rpc.amqp File "/usr/lib/python2.7/contextlib.py", line 24, in __exit__
2013-10-09 02:23:12.532 5475 TRACE cinder.openstack.common.rpc.amqp self.gen.next()
2013-10-09 02:23:12.532 5475 TRACE cinder.openstack.common.rpc.amqp File "/root/work/cinder3/cinder/cinder/volume/manager.py", line 549, in copy_volume_to_image
2013-10-09 02:23:12.532 5475 TRACE cinder.openstack.common.rpc.amqp image_meta)
2013-10-09 02:23:12.532 5475 TRACE cinder.openstack.common.rpc.amqp File "/root/work/cinder3/cinder/cinder/volume/drivers/vmware/vmdk.py", line 688, in copy_volume_to_image
2013-10-09 02:23:12.532 5475 TRACE cinder.openstack.common.rpc.amqp raise exception.InvalidVolume(msg % volume['status'])
2013-10-09 02:23:12.532 5475 TRACE cinder.openstack.common.rpc.amqp InvalidVolume: Upload to glance of volume not supported in state: uploading.
2013-10-09 02:23:12.532 5475 TRACE cinder.openstack.common.rpc.amqp

Subbu (subramanian-neelakantan) wrote :

This is a regression caused by the fix to bug #1236891.

Fix proposed to branch: master
Review: https://review.openstack.org/50595

Changed in cinder:
assignee: nobody → Subbu (subramanian-neelakantan)
status: New → In Progress

This needs to get in, else upload to glance will always fail.

Changed in cinder:
importance: Undecided → High

Reviewed: https://review.openstack.org/50595
Committed: http://github.com/openstack/cinder/commit/a2b774c0ce2a1aaa9cdfc7d7c4c4d642f1bfc3d1
Submitter: Jenkins
Branch: master

commit a2b774c0ce2a1aaa9cdfc7d7c4c4d642f1bfc3d1
Author: Subramanian Neelakantan <subbu@ubuntu.(none)>
Date: Wed Oct 9 03:53:52 2013 -0700

    VMware: Fixed upload-to-image for available volume

    Cinder generally does not allow upload-to-image operation on a volume
    that is 'in-use'. This can however be over-ridden using the '--force True'
    flag. The VMware driver cannot support upload-to-image when the volume is
    in-use. This is a restriction for the VMware driver alone. When the user forces
    an upload on a volume that is 'in-use' the Cinder api layer sets the volume
    status to 'uploading' and calls into the driver code to upload. In this
    scenario the VMware driver needs to fail the operation.

    The current driver code here does this check wrongly by looking for volume
    status of 'in-use'. Fixing this check to identify an in-use volume correctly.

    Fixes bug: 1237338

    Change-Id: If54edfdc242a7a1bff442b6bb4c5a9865eede1dc

Changed in cinder:
status: In Progress → Fix Committed
tags: added: havana-backport-potential
removed: havana-rc-potential
Thierry Carrez (ttx) on 2013-12-04
Changed in cinder:
milestone: none → icehouse-1
status: Fix Committed → Fix Released
Tracy Jones (tjones-i) on 2014-02-25
Changed in openstack-vmwareapi-team:
importance: Undecided → High
status: New → Fix Released
Alan Pevec (apevec) on 2014-03-27
tags: removed: havana-backport-potential

Reviewed: https://review.openstack.org/81357
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=62d4e54a24ee92dd4dd05eac410c1f9162757a74
Submitter: Jenkins
Branch: stable/havana

commit 62d4e54a24ee92dd4dd05eac410c1f9162757a74
Author: Subramanian Neelakantan <subbu@ubuntu.(none)>
Date: Wed Oct 9 03:53:52 2013 -0700

    VMware: Fixed upload-to-image for available volume

    Cinder generally does not allow upload-to-image operation on a volume
    that is 'in-use'. This can however be over-ridden using the '--force True'
    flag. The VMware driver cannot support upload-to-image when the volume is
    in-use. This is a restriction for the VMware driver alone. When the user forces
    an upload on a volume that is 'in-use' the Cinder api layer sets the volume
    status to 'uploading' and calls into the driver code to upload. In this
    scenario the VMware driver needs to fail the operation.

    The current driver code here does this check wrongly by looking for volume
    status of 'in-use'. Fixing this check to identify an in-use volume correctly.

    Fixes bug: 1237338

    (cherry picked from commit a2b774c0ce2a1aaa9cdfc7d7c4c4d642f1bfc3d1)

    Change-Id: If54edfdc242a7a1bff442b6bb4c5a9865eede1dc

Thierry Carrez (ttx) on 2014-04-17
Changed in cinder:
milestone: icehouse-1 → 2014.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers