Previous change to allow SolidFire to clone different size, breaks create-snapshot

Bug #1234970 reported by John Griffith on 2013-10-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Critical
John Griffith
Grizzly
Critical
John Griffith

Bug Description

Change-Id: I5628c7fa922780d6b0601e2daa79310a61085edc was introduced to fix/allow the ability to specify new sizes on clone volume. Unfortunately this breaks create-snapshot which shares the method because the snapshot ref that's passed in doesn't have a "size" member (it's "volume_size").

Fix proposed to branch: master
Review: https://review.openstack.org/49648

Changed in cinder:
status: Triaged → In Progress

Reviewed: https://review.openstack.org/49648
Committed: http://github.com/openstack/cinder/commit/3cd27defb1c820ceadd8bbc6bfd5a405a7376cdb
Submitter: Jenkins
Branch: master

commit 3cd27defb1c820ceadd8bbc6bfd5a405a7376cdb
Author: John Griffith <email address hidden>
Date: Thu Oct 3 15:54:20 2013 -0600

    Fix broken solidfire create-snapshot

    A previous change to enable secifying size for cloned volumes
    created introduced a bug that breaks the ability to create-snapshots
    when using the SolidFire driver
    (CID: I5628c7fa922780d6b0601e2daa79310a61085edc).

    The problem is that we use a shared method in the SF driver for both
    create-clone and create-snapshot, the added change only considers the
    clone case and does a get ref['size'] but in the case of snapshots
    this needs to be ref['volume_size'].

    Change-Id: I50603b3ac43f2c3c7e7811ec34de078a268519f7
    Closes-Bug: 1234970

Changed in cinder:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/49693
Committed: http://github.com/openstack/cinder/commit/f021629df31328324ca429c29a827efab832eee0
Submitter: Jenkins
Branch: milestone-proposed

commit f021629df31328324ca429c29a827efab832eee0
Author: John Griffith <email address hidden>
Date: Thu Oct 3 15:54:20 2013 -0600

    Fix broken solidfire create-snapshot

    A previous change to enable secifying size for cloned volumes
    created introduced a bug that breaks the ability to create-snapshots
    when using the SolidFire driver
    (CID: I5628c7fa922780d6b0601e2daa79310a61085edc).

    The problem is that we use a shared method in the SF driver for both
    create-clone and create-snapshot, the added change only considers the
    clone case and does a get ref['size'] but in the case of snapshots
    this needs to be ref['volume_size'].

    Change-Id: I50603b3ac43f2c3c7e7811ec34de078a268519f7
    Closes-Bug: 1234970
    (cherry picked from commit 3cd27defb1c820ceadd8bbc6bfd5a405a7376cdb)

Changed in cinder:
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/50099
Committed: http://github.com/openstack/cinder/commit/27e5674c896e7969d6efc37c0514faf57499d724
Submitter: Jenkins
Branch: stable/grizzly

commit 27e5674c896e7969d6efc37c0514faf57499d724
Author: John Griffith <email address hidden>
Date: Thu Oct 3 15:54:20 2013 -0600

    Fix broken solidfire create-snapshot

    A previous change to enable secifying size for cloned volumes
    created introduced a bug that breaks the ability to create-snapshots
    when using the SolidFire driver
    (CID: I5628c7fa922780d6b0601e2daa79310a61085edc).

    The problem is that we use a shared method in the SF driver for both
    create-clone and create-snapshot, the added change only considers the
    clone case and does a get ref['size'] but in the case of snapshots
    this needs to be ref['volume_size'].

    Closes-Bug: 1234970

    Change-Id: I50603b3ac43f2c3c7e7811ec34de078a268519f7

tags: added: in-stable-grizzly
Thierry Carrez (ttx) on 2013-10-17
Changed in cinder:
milestone: havana-rc1 → 2013.2
Alan Pevec (apevec) on 2014-03-31
tags: removed: in-stable-grizzly
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers