Storwize SVC driver hostname can't start with number

Bug #1233952 reported by Alan Jiang on 2013-10-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Undecided
Alan Jiang

Bug Description

Host name identifier can not start with numeric number on Storwize family storage . Otherwise
the initialize_connection will fail with exception when connector has invalid host name.

Alan Jiang (ajiang) on 2013-10-02
Changed in cinder:
status: New → Confirmed
assignee: nobody → Alan Jiang (ajiang)
Changed in cinder:
status: Confirmed → In Progress
tags: added: drivers storwize

Reviewed: https://review.openstack.org/49104
Committed: http://github.com/openstack/cinder/commit/a9b51ea8421939ddc1d9a964dd58a1067fc2a167
Submitter: Jenkins
Branch: master

commit a9b51ea8421939ddc1d9a964dd58a1067fc2a167
Author: Alan Jiang <email address hidden>
Date: Tue Oct 1 00:38:03 2013 -0500

    Storwize SVC driver hostname can't start with number

    Storwize family storage does not allow host identifier start with
    a numeric number. Otherwise cinder initialize_connection() API will
    throw exception due to such invalid host name in the connector. The fix
    is to add a '_' symbol as prefix if the host identifier in connector
    starts with non-alphabet letters.

    Closes-Bug: #1233952
    Change-Id: Ia88afc373e2635c10c3f6256331a4fd90f51f4b8

Changed in cinder:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-10-04
Changed in cinder:
milestone: none → havana-rc1
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in cinder:
milestone: havana-rc1 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers