HP3PAR iSCSI driver does not use previously established target iqn connections

Bug #1224594 reported by Jim Branen on 2013-09-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Undecided
Jim Branen

Bug Description

When using multiple iSCSI ports, the HP3PAR iSCSI driver should first identify if an iSCSI connection has already been established between initiator/target and reuse it. If no connection has been established, the driver should select the least busy 3PAR port to use.

Currently, the iSCSI driver is always selecting the least busy port. This may result in multiple connections between initiator/target.

Changed in cinder:
status: New → Confirmed
Changed in cinder:
assignee: nobody → Jim Branen (james-branen)

Fix proposed to branch: master
Review: https://review.openstack.org/47597

Changed in cinder:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/47597
Committed: http://github.com/openstack/cinder/commit/f1e67f5140ef35bfa8bef53adbc17d0ef9ddba33
Submitter: Jenkins
Branch: master

commit f1e67f5140ef35bfa8bef53adbc17d0ef9ddba33
Author: Jim Branen <email address hidden>
Date: Fri Sep 20 08:41:44 2013 -0700

    Fix HP3PAR iSCSI path connection

    The iSCSI paths are not correctly identified as ‘active’
    when port information is requested from the hp3parclient
    because the ‘active’ value is a Boolean not the string
    ‘true’.

    Fixes Bug #1224594

    Change-Id: Ib10563cfc31c0628dc8b1edbba246398a3a11f34

Changed in cinder:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-10-04
Changed in cinder:
milestone: none → havana-rc1
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in cinder:
milestone: havana-rc1 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers