NetApp driver should disallow very old controller OS versions

Bug #1223474 reported by Ben Swartzlander on 2013-09-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Medium
Navneet
Grizzly
Medium
Navneet

Bug Description

The NetApp drivers have been tested with various software versions, from 7.3 - 8.2. Versions 7.2 and older are unsupported, and the driver should detect the OS version at runtime and throw an error if it detects a version that is too old. This will reduce bugs and support issues related to people running unsupported versions.

Navneet (singn) on 2013-09-14
Changed in cinder:
status: New → Confirmed
assignee: nobody → Navneet (singn)

Fix proposed to branch: master
Review: https://review.openstack.org/46709

Changed in cinder:
status: Confirmed → In Progress
Changed in cinder:
milestone: none → havana-rc1
importance: Undecided → Medium

Reviewed: https://review.openstack.org/46709
Committed: http://github.com/openstack/cinder/commit/1af8f46ea1c8e2a33ca554fa6ef3262d055c54ed
Submitter: Jenkins
Branch: master

commit 1af8f46ea1c8e2a33ca554fa6ef3262d055c54ed
Author: Navneet Singh <email address hidden>
Date: Tue Jul 30 17:37:44 2013 +0530

    NetApp check for 7 mode controller version

    Queries the filer api version and raises error
    if the version is unsupported.

    Closes-Bug:#1223474

    Change-Id: I430a41d63a2541891fdbdb20dacab9f69fa44291

Changed in cinder:
status: In Progress → Fix Committed
tags: added: grizzly-backport-potential
Navneet (singn) on 2013-10-03
tags: added: navneet-netapp-backport

Fix proposed to branch: stable/grizzly
Review: https://review.openstack.org/49684

Thierry Carrez (ttx) on 2013-10-04
Changed in cinder:
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/49684
Committed: http://github.com/openstack/cinder/commit/6e764cbf0fd90beb0e2f918903696a57ed198376
Submitter: Jenkins
Branch: stable/grizzly

commit 6e764cbf0fd90beb0e2f918903696a57ed198376
Author: Navneet Singh <email address hidden>
Date: Tue Jul 30 17:37:44 2013 +0530

    NetApp check for 7 mode controller version

    Queries the filer api version and raises error
    if the version is unsupported.

    Closes-Bug:#1223474

    Conflicts:

     cinder/tests/test_netapp.py
     cinder/tests/test_netapp_nfs.py
     cinder/volume/drivers/netapp/iscsi.py
     cinder/volume/drivers/netapp/nfs.py

    Change-Id: I430a41d63a2541891fdbdb20dacab9f69fa44291
    (cherry picked from commit 1af8f46ea1c8e2a33ca554fa6ef3262d055c54ed)

tags: added: in-stable-grizzly
Thierry Carrez (ttx) on 2013-10-17
Changed in cinder:
milestone: havana-rc1 → 2013.2
Alan Pevec (apevec) on 2014-03-31
tags: removed: grizzly-backport-potential in-stable-grizzly
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers