ImageUnacceptable exceptions are not properly raised from image_utils.fetch_to_raw()

Bug #1209021 reported by Jay Bryant on 2013-08-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Undecided
Jay Bryant

Bug Description

ImageUnacceptable errors are currently just being handled by _copy_image_to_volume and being made ImageCopyFailure exception. In the case that fetch_to_raw actually encounters an ImageUnacceptable exception it is not clear that this is what has happened with the way the exception is currently being handled.

The ImageUnacceptable errors should, instead be raised as the same type of exception and then handled create_volume in the same manner an ImageCopyFailure is handled.

Jay Bryant (jsbryant) on 2013-08-06
Changed in cinder:
assignee: nobody → Jay Bryant (jsbryant)

Fix proposed to branch: master
Review: https://review.openstack.org/41473

Changed in cinder:
status: New → In Progress

Reviewed: https://review.openstack.org/41473
Committed: http://github.com/openstack/cinder/commit/9404eb1591cd5133d8ed9d1675f809b221ff2cde
Submitter: Jenkins
Branch: master

commit 9404eb1591cd5133d8ed9d1675f809b221ff2cde
Author: Jay S. Bryant <email address hidden>
Date: Mon Aug 12 11:46:06 2013 -0500

    Fix handling ImageUnacceptable in create_volume

    In the create_volume flow ImageUnacceptable exceptions are
    not properly handled. _copy_image_to_volume can receive an
    ImageUnacceptable exception from copy_image_to_volume if fetch_to_raw
    is used. Currently the ImageUnacceptable exception is changed to
    a generic ImageCopyFailure exception which does not make the cause
    of the excpetion clear.

    This change adds handling and raising ImageUnacceptable exceptions
    in _copy_image_to_volume. It also adds the exception to
    no_reschedule_types as it doesn't make sense to keep retrying the
    copy if the image was found to be unacceptable.

    fixes bug 1209021

    Change-Id: I9aacf23dfaaa1a4df0a869d1c9544c376488f01b

Changed in cinder:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-09-05
Changed in cinder:
milestone: none → havana-3
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in cinder:
milestone: havana-3 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers