3par -online option missing from createvvcopy hp_3par_common.py

Bug #1208586 reported by Michael Denny on 2013-08-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Medium
Kurt Martin

Bug Description

cinder/volume/drivers/san/hp/hp_3par_common.py
line 787
  self._cli_run('createvvcopy -p %s %s' % (src_name, dest_name), None)

need to add -online option
    -online
        Specifies that the copy is to be performed online. This means that the
        destination can be immediately exported and is automatically created by
        this command, meaning that it cannot exist prior to executing this
        command. This option requires the specification of a CPG for the
        destination volume and allows for the -snp_cpg and -tpvv optional
        options. Finally, -online requires the -p option and is incompatible
        with the -r, -halt, -s, -b, and -pri options.

Mike Perez (thingee) on 2013-08-06
tags: added: 3par drivers
Changed in cinder:
status: New → Confirmed
Changed in cinder:
assignee: nobody → Walt Boring (walter-boring)
importance: Undecided → Medium
milestone: none → havana-3
Changed in cinder:
assignee: Walt Boring (walter-boring) → Kurt Martin (kurt-f-martin)

Fix proposed to branch: master
Review: https://review.openstack.org/41787

Changed in cinder:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/41787
Committed: http://github.com/openstack/cinder/commit/de31210c05f464c4a79255de68b1a515d9b84ed3
Submitter: Jenkins
Branch: master

commit de31210c05f464c4a79255de68b1a515d9b84ed3
Author: Kurt Martin <email address hidden>
Date: Tue Aug 13 13:51:15 2013 -0700

    Adding the -online option to the 3PAR clone

    The 3PAR drivers had to wait while the clone was being performed
    and this would take a considerable amount of time for large volumes.
    This patch takes advantage of the 3PAR backend by using the -online
    option in the command that we were calling to perform the copy. This
    allows us to remove the sleep in the driver. Using the -online
    option forced us to change some of the delete_volume code because
    the 3PAR backend will not allow a volume that was copied to be added
    to a virtual volume set.

    DocImpact

    Change-Id: I47d72063c858e2eee10756be4f74febdd1603179
    Fixes: bug 1208586

Changed in cinder:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-09-05
Changed in cinder:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in cinder:
milestone: havana-3 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers