need_longer_timeout_setting_for_solidfire_clone

Bug #1202007 reported by John Griffith on 2013-07-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
High
John Griffith
Grizzly
High
John Griffith

Bug Description

Current timeout value for clone volume in the SolidFire driver is 20 seconds, this is fine in many cases however there seems to be a number of customers doing clones of volumes >= 400G. A populated 400G volume is taking upwards of 35 seconds in some cases resulting in failure.

There's no reason not to bump this timeout value up significantly to a worst case scenario (ie multi-terrabyte volume).

Fix proposed to branch: master
Review: https://review.openstack.org/37358

Changed in cinder:
status: Confirmed → In Progress
Changed in cinder:
importance: Undecided → High

Reviewed: https://review.openstack.org/37358
Committed: http://github.com/openstack/cinder/commit/9ce7cdbaeb73031d841cb0943ca1812b149d1c19
Submitter: Jenkins
Branch: master

commit 9ce7cdbaeb73031d841cb0943ca1812b149d1c19
Author: John Griffith <email address hidden>
Date: Tue Jul 16 18:27:19 2013 -0600

    Increase timeout period for clone volume.

    Current timeout value for clone volume in the
    SolidFire driver is 20 seconds, this is fine
    in many cases however there seems to be a
    number of customers doing clones of
    volumes >= 400G.

    A populated 400G volume is taking upwards of
    35 seconds to clone in some cases resulting in failure.

    There's no reason not to bump this timeout value up
    significantly to a worst case scenario (ie multi-terrabyte volume).

    Fixes bug: 1202007

    Change-Id: I98c399f5d647e14f031018f7fc1cc43bb0d94c84

Changed in cinder:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-07-17
Changed in cinder:
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/37362
Committed: http://github.com/openstack/cinder/commit/110133e2a5a90a01b983dea5fd892010082965a8
Submitter: Jenkins
Branch: stable/grizzly

commit 110133e2a5a90a01b983dea5fd892010082965a8
Author: John Griffith <email address hidden>
Date: Tue Jul 16 18:27:19 2013 -0600

    Increase timeout period for clone volume.

    Current timeout value for clone volume in the
    SolidFire driver is 20 seconds, this is fine
    in many cases however there seems to be a
    number of customers doing clones of
    volumes >= 400G.

    A populated 400G volume is taking upwards of
    35 seconds to clone in some cases resulting in failure.

    There's no reason not to bump this timeout value up
    significantly to a worst case scenario (ie multi-terrabyte volume).

    Fixes bug: 1202007

    Change-Id: I98c399f5d647e14f031018f7fc1cc43bb0d94c84
    (cherry picked from commit 9ce7cdbaeb73031d841cb0943ca1812b149d1c19)

Alan Pevec (apevec) on 2013-08-06
tags: removed: grizzly-backport-potential
Thierry Carrez (ttx) on 2013-10-17
Changed in cinder:
milestone: havana-2 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers