3Par driver required scoping of the extra-spec keys

Bug #1194289 reported by Kurt Martin on 2013-06-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Medium
Kurt Martin

Bug Description

The filter scheduler late in the Grizzly release cycle changed some of the behavior when creating a volume based on a type with extra-specs. Currently users would have to use the Simple Scheduler in order for them to work correctly.

The Filter scheduler uses the extra-specs data to determine capabilities and back-end, and it also enforces strict checking. As a result previous method of setting all the 3PAR settings(cpg, snap_cpg, persona, provisioning) on the 3PAR volume using extra-specs on a volume type will not work with the default scheduler.The filter scheduler will look at this keys and fail to schedule deployment of the volume because no suitable back-end reports those capabilities.

To fix this all we need to do is scope the custom keys (ie: hp3par:cpg=TEST_CPG, hp3par:provisioning=full,....), unfortunately this requires an additional check in the driver to parse the key.

Changed in cinder:
assignee: nobody → Kurt Martin (kurt-f-martin)
summary: - 3Par driver required scoping of the extra_spec keys
+ 3Par driver required scoping of the extra-spec keys
Changed in cinder:
importance: Undecided → Medium
status: New → Confirmed
tags: added: drivers

Fix proposed to branch: master
Review: https://review.openstack.org/34273

Changed in cinder:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/34273
Committed: http://github.com/openstack/cinder/commit/bbc4b9abd7c2034ef78f87abae143b9c7bfd7f56
Submitter: Jenkins
Branch: master

commit bbc4b9abd7c2034ef78f87abae143b9c7bfd7f56
Author: Kurt Martin <email address hidden>
Date: Sun Dec 23 16:47:58 2012 -0800

    Added extra-spec key scoping to the 3PAR drivers

    The Filter scheduler uses the extra-specs data to determine capabilities
    and back-end, and it also enforces strict checking. As a result previous
    method of setting all the 3PAR settings(cpg, snap_cpg, persona, provisioning)
    on the 3PAR volume using extra-specs on a volume type will not work with the
    default scheduler. The filter scheduler will look at these keys and fail to
    schedule deployment of the volume because no suitable back-end reports those
    capabilities.

    This fix will allow the custom keys (ie: hp3par:cpg=TEST_CPG,
    hp3par:provisioning=full,...) to be scoped, unfortunately this requires
    additional checks in the common driver to parse the keys.

    I'll update the 3PAR driver section of the OpenStack Block Storage Admin
    Guide in a follow-up patch.
    DocImpact
    Fixes: bug 1194289

    Change-Id: Id3fde3b3a185eedf2b8193fd0dc6324d904e8834

Changed in cinder:
status: In Progress → Fix Committed
Changed in cinder:
milestone: none → havana-2
Thierry Carrez (ttx) on 2013-07-17
Changed in cinder:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in cinder:
milestone: havana-2 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers