Cinder cannot use glance's ssl_compression feature

Bug #1189903 reported by Stuart McLaren on 2013-06-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Undecided
Stuart McLaren

Bug Description

The glance client allows disabling ssl_compression.
The option to do this should be added to cinder as it can provide a performance boost.

Changed in cinder:
assignee: nobody → Stuart McLaren (stuart-mclaren)

Fix proposed to branch: master
Review: https://review.openstack.org/32572

Changed in cinder:
status: New → In Progress

Reviewed: https://review.openstack.org/32572
Committed: http://github.com/openstack/cinder/commit/c927949616be6e961b2750a3dbe1935f875455fd
Submitter: Jenkins
Branch: master

commit c927949616be6e961b2750a3dbe1935f875455fd
Author: Stuart McLaren <email address hidden>
Date: Tue Jun 11 13:55:20 2013 +0000

    Allow disabling ssl compression for glance client

    Add a new parameter 'glance_api_ssl_compression' which allows
    disabling ssl layer compression negotiation for glance requests.

    This may improve data throughput, eg when high network bandwidth is
    available and you are using already compressed image formats such as
    qcow2 .

    Addresses bug 1189903.

    Change-Id: I180501cc25a1ea177d0d8c52a879682b8a3921c6

Changed in cinder:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-07-17
Changed in cinder:
milestone: none → havana-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in cinder:
milestone: havana-2 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers