Some tests are skipped because of the execute bit

Bug #1183416 reported by Julien Danjou on 2013-05-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
High
Avishay Traeger

Bug Description

The following files:

cinder/tests/integrated/test_volumes.py
cinder/tests/test_storwize_svc.py

have the +x bit set, which isn't correct and got them ignored by nosetests.

Changed in cinder:
assignee: nobody → Avishay Traeger (avishay-il)
importance: Undecided → High
status: New → Confirmed
milestone: none → havana-1

Fix proposed to branch: master
Review: https://review.openstack.org/30394

Changed in cinder:
status: Confirmed → In Progress
Thierry Carrez (ttx) wrote :

Pushing back to H2, please set back to H1 if this is milestone-critical (in which case the fix needs to land in master first and then be backported to milestone-proposed before tomorrow)

Changed in cinder:
milestone: havana-1 → havana-2

Reviewed: https://review.openstack.org/30394
Committed: http://github.com/openstack/cinder/commit/fa6404eb026b45c8194b586498a7df38143a4eca
Submitter: Jenkins
Branch: master

commit fa6404eb026b45c8194b586498a7df38143a4eca
Author: Avishay Traeger <email address hidden>
Date: Fri May 24 11:19:51 2013 +0300

    Remove execute permissions from test files.

    Remove execute permissions from test_volumes.py and
    test_storwize_svc.py, which caused the tests defined in them
    to be skipped.

    Fixing the permissions caused test_create_volume_with_volume_type to
    execute, which fails. The cause of the failure is that
    (1) LoggingVolumeDriver doesn't implement get_volume_stats(), and
    (2) The fake RPC doesn't pass the statistics to the scheduler for
    some reason.

    Because this test doesn't test the scheduler, just change to use the
    simple scheduler and work around the issue.

    Change-Id: Ie01331d484c5c48c78b626eff1ad793dbbe7182c
    Fixes: bug 1183416

Changed in cinder:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-07-17
Changed in cinder:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in cinder:
milestone: havana-2 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers