tools/conf/generate_sample.sh seems to be broken

Bug #1182611 reported by Morgan Fainberg on 2013-05-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Cinder
Undecided
Anton Frolov

Bug Description

Trying to generate a new sample config (to reflect changes in options) doesn't seem to work properly. There are many options that are missing from the new sample config when the script is run.

The script reports no errors and has no logging so there is no direct indication of what might be wrong with it at this time.

Eric Harney (eharney) wrote :

There is a substantial delta between Cinder's extract_opts.py and Nova's -- probably need to start there and see if we can sync their changes over.

Changed in cinder:
assignee: nobody → Avishay Traeger (avishay-il)
status: New → Confirmed
Changed in cinder:
assignee: Avishay Traeger (avishay-il) → nobody
Anton Frolov (anton0) on 2013-05-31
Changed in cinder:
assignee: nobody → Anton Frolov (anton0)

Fix proposed to branch: master
Review: https://review.openstack.org/31180

Changed in cinder:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/31180
Committed: http://github.com/openstack/cinder/commit/27e261376fc03655a5f90603078a3a8623ddf32f
Submitter: Jenkins
Branch: master

commit 27e261376fc03655a5f90603078a3a8623ddf32f
Author: Anton Frolov <email address hidden>
Date: Fri May 31 14:27:49 2013 +0400

    Add error reporting to generate_sample.sh on import failure.

    Currently tools/conf/generate_sample.sh collect options from project
    modules by importing each module and looking at it's global variables
    for instances of classes derived from cfg.Opt (or lists of such
    instances). Sometimes this import can fail due to various reasons,
    cfg.DuplicateOptError for example. And if import fails no options
    from imported module written to sample config file. Error reporting
    will at least warn user that some of options didn't get into sample
    config.

    Change-Id: I831464b1c1575c106d866a936a50ec74b2d44e59
    Fixes: bug #1182611

Changed in cinder:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-07-17
Changed in cinder:
milestone: none → havana-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in cinder:
milestone: havana-2 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers