cinder fail test_schedule_happy_day test

Bug #1171906 reported by Yaroslav on 2013-04-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Medium
Vincent Hou

Bug Description

Hello, here is problem: If I install cinder, it fail one test. Here is traceback: http://paste.openstack.org/show/36544/

John Griffith (john-griffith) wrote :

I appears that the problem here is that the fake is never doing the update capabilities back to the scheduler, so it's just holding the default value of 'None' for the free_capacity_gb when checked here.

Changed in cinder:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → havana-1
Vincent Hou (houshengbo) on 2013-05-23
Changed in cinder:
assignee: nobody → Vincent Hou (houshengbo)

Fix proposed to branch: master
Review: https://review.openstack.org/30261

Changed in cinder:
status: Confirmed → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/30264

Reviewed: https://review.openstack.org/30264
Committed: http://github.com/openstack/cinder/commit/561520447de9b89db7f052e31fc9d5f7d416b5dc
Submitter: Jenkins
Branch: master

commit 561520447de9b89db7f052e31fc9d5f7d416b5dc
Author: Vincent Hou <email address hidden>
Date: Thu May 23 19:54:36 2013 +0800

    Add the service_state into test_schedule_happy_day.

    Since the fake filter scheduler does not update the capabilities, the sevice
    states remains empty. To avoid the None value for free_capacity_gb, we set the
    host_manager to a fake host manager with a list of service states.

    Fixed Bug 1171906.

    Change-Id: I359ea6952392cc5e6b8eff513f3ca4d8161a30e3

Changed in cinder:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-05-29
Changed in cinder:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in cinder:
milestone: havana-1 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers