MultiBackend naming convention not compatable with zmq

Bug #1166899 reported by John Griffith on 2013-04-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Medium
Vincent Hou

Bug Description

Cinders multi-backend implemenation chose to use the form 'cinder-volume:<host>@<driver-name>' as the host entry . This unfortunately is not compatable with zmq.

For zmq we need it to be something like: 'cinder-volume:<driver-name>.<host>'.

Chuck Short (zulcss) on 2013-04-11
Changed in cinder:
status: New → Confirmed
Changed in cinder:
milestone: havana-1 → havana-2
Vincent Hou (houshengbo) on 2013-06-08
Changed in cinder:
assignee: nobody → Vincent Hou (houshengbo)

Fix proposed to branch: master
Review: https://review.openstack.org/33630

Changed in cinder:
status: Confirmed → In Progress
Vincent Hou (houshengbo) wrote :
Download full text (9.7 KiB)

I have been testing this issue today. I was using the latest codea dn devstack.
My conclusion is that the reason for this bug is not the naming convention and I guess it is due to the consumer register in create_consumer in impl_zmq.py.

First, there is an issue with the creation of dir /var/run/openstack. Although oslo claims it has been fixed, I still find it fails to create the dir because of permission denied. I have manually create the dir /var/run/openstack, and run "sudo chmod 777 ...." with it.

Then, set CINDER_MULTI_LVM_BACKEND=True in the localrc for devstack. Try to run ./stack.sh. This time, I find it is very strage that if node_topic in cinder/cinder/service.py contains ".", it will raise an exception: Operation against a key holding the wrong kind of value. When I change the "." into other characters like "@" or ":", there will be no exception.

After I change the delimiter to ":" for node_topic in cinder/cinder/service.py and topic = '.'.join((topic.split('.', 1)[0], CONF.rpc_zmq_host)) to topic = '.'.join((topic.split(':', 1)[0], CONF.rpc_zmq_host)) in impl_zmq.py, I can have all my openstack services running. I test with "cinder create 1" and get the following log for cinder-scheduler:
===============================================cinder-scheduler========================================
2013-07-11 19:30:29.679 DEBUG cinder.openstack.common.rpc.common [-] u'cinder-volume.openstack-node@lvmdriver-1' {'args': {'allow_resc
hedule': True,
          'filter_properties': {'availability_zone': u'nova',
                                'config_options': {},
                                'metadata': {},
                                'request_spec': {u'image_id': None,
                                                 'resource_properties': {u'attach_status': u'detached',
                                                                         u'availability_zone': u'nova',
                                                                         u'display_description': None,
                                                                         u'display_name': None,
                                                                         u'id': u'6adb0787-75b6-4684-a459-f6b54d6f4275',
                                                                         u'metadata': {},
                                                                         u'project_id': u'642638244f834834aa9eb1331c38acfa',
                                                                         u'size': 1,
                                                                         u'snapshot_id': None,
                                                                         u'source_volid': None,
                                                                         u'status': u'creating',
                                                                         u'user_id': u'87d29d0b45d14d9a8435d074e7cd00bb',
                                                                         u'volume_metadata': [],
                                                                         u'volume_type_id': None},
                                                 u'snapsh...

Read more...

Fix proposed to branch: master
Review: https://review.openstack.org/36794

Vincent Hou (houshengbo) wrote :

This bug is not due to the host entry, but due to the incorrect node_topic registration in ZMQ. Please check the commit message of Patch https://review.openstack.org/36794 for the details.
.

Changed in cinder:
milestone: havana-2 → havana-3
Vincent Hou (houshengbo) wrote :
Changed in cinder:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-09-05
Changed in cinder:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in cinder:
milestone: havana-3 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers