Cinder API log WARNING: Inheritance-based rules are deprecated

Bug #1156608 reported by Dan Prince on 2013-03-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Cinder
High
Rushi Agrawal

Bug Description

Using the latest version of Cinder Grizzly I'm seeing the following log WARNING errors in my /var/log/cinder/api.log on Fedora:

2013-03-18 09:44:59.621 16924 WARNING cinder.openstack.common.policy [-] Inheritance-based rules are deprecated; use the default brain instead of HttpBrain.

Dan Prince (dan-prince) on 2013-03-18
Changed in cinder:
importance: Undecided → High
Chuck Short (zulcss) on 2013-04-11
Changed in cinder:
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/30680

Changed in cinder:
assignee: nobody → Rushi Agrawal (rushiagr)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/30680
Committed: http://github.com/openstack/cinder/commit/0f7865bfb0cf8d328df395e583d3889e5dcf39d1
Submitter: Jenkins
Branch: master

commit 0f7865bfb0cf8d328df395e583d3889e5dcf39d1
Author: Rushi Agrawal <email address hidden>
Date: Mon May 27 19:48:12 2013 +0530

    Fix 'Inheritance-based rule deprecated' log warning

    A warning message appears in Cinder logs which state that
    inheritance-based rules are deprecated and use default
    Brain instead of HttpBrain. It looks like HttpBrain class
    doesnt have any difference from Brain class, so changing
    all the instances of HttpBrain to Brain shouldn't affect
    anything and removes this warning from logs.

    Digging further, I found out that the policy engine has
    gone through a major rework in Oslo and Nova, and I think
    at some point of time in future, we will also be moving
    to use the latest policy engine code. In that way of
    thinking, I guess this fix is acceptable for now.
    Reference: https://review.openstack.org/#/c/14122

    Changed the brain from HttpBrain -> Brain, which makes the
    warnings in the log disapper. A more comprehensive work will be
    to pull the latest policy change code from Oslo.

    Bug #1156608

    Change-Id: I9f63ec4c41025042725db9b2e7c8ffa3d91e0596

Changed in cinder:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-07-17
Changed in cinder:
milestone: none → havana-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in cinder:
milestone: havana-2 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers