FLAGS are only used once in cinder/volume/manager.py use configuration instead

Bug #1153551 reported by Ollie Leahy on 2013-03-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
High
Ollie Leahy

Bug Description

bot self.configuration and FLAGS are used in cinder/volume/manager.py. But FLAGs are only used once so we could migrate that to configuration and remove the reference to FLAGS from the module.

Changed in cinder:
assignee: nobody → Ollie Leahy (oliver-leahy-l)
Changed in cinder:
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/24661

Changed in cinder:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/24661
Committed: http://github.com/openstack/cinder/commit/d75671cce045b61e1a00642f815a89c129cda177
Submitter: Jenkins
Branch: master

commit d75671cce045b61e1a00642f815a89c129cda177
Author: Ollie Leahy <email address hidden>
Date: Mon Mar 18 18:05:02 2013 +0000

    Remove references to FLAGS from volume/manager.py

    Note that we still must import flags.py because volume_topic is defined
    in the list global_opts in flags.py.

    Fixes bug #1153551

    Change-Id: I3d37bde4ba895c110390cea92385344ff94cb7d1

Changed in cinder:
status: In Progress → Fix Committed
Changed in cinder:
milestone: none → grizzly-rc2
importance: Undecided → High
milestone: grizzly-rc2 → none
Thierry Carrez (ttx) on 2013-05-29
Changed in cinder:
milestone: none → havana-1
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in cinder:
milestone: havana-1 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers