Doesn't show HTML notifications in notify-osd.

Bug #717538 reported by John P. Royal on 2011-02-12
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Chromify-OSD
Status tracked in Extension
Extension
Medium
Marco Ceppi

Bug Description

Not sure if it's meant to or not, but by installing the way I did (link below, method of installation was edited into answer), the only notifications I recieve are those that don't seem to be HTML.

http://askubuntu.com/questions/25811/chrome-desktop-notifications-use-notify-osd

At this test page,

http://www.phpguru.org/html5-webkit-desktop-notifications-example

it only displays notifications from the first button (Notify me!) not the second (Notify me! (HTML)). Also, it doesn't work with any web applications that use desktop notifications, like imo.im.

Marco Ceppi (marcoceppi) wrote :

This is by design for now. Originally is supported both HTML and Webkit however, items in HTML notifications far succeed that of what libnotify can handle (Multiple images, tabs, colorization, HTML Anchor links) so the decision was made to leave HTML Stylized notifications alone. If libnotify or another notification solution comes along that supports more extensive markup we can re-evaluate.

Also, not far out of the realm of possibility, but future releases of this plugin will have a settings page where this option could be enabled in (Parse/don't parse HTML notifications)

Changed in chromify-osd:
status: New → Won't Fix
importance: Undecided → Wishlist
status: Won't Fix → New
Marco Ceppi (marcoceppi) on 2011-02-16
Changed in chromify-osd:
status: New → Confirmed
Marco Ceppi (marcoceppi) on 2011-02-17
Changed in chromify-osd:
milestone: none → 2.2
assignee: nobody → Marco Ceppi (marco-ceppi)
Rod Davis (ahylianhuman) wrote :

On Ubuntu 10.10 and the latest Chrome stable, the regular "Notify Me!" button (the non-HTML one) results in nothing showing up. Nothing from libnotify, nothing from Chrome's built-in notifications. Disabling this plugin allows them to show. I installed this plugin from the Chrome Web Store.

Marco Ceppi (marcoceppi) wrote :

Rod, can you please create a separate bug report for this, Including the exact version of Chrome you are using, etc. I have been hearing scattered reports that the extension does not work in Chrome on 10.10 but no one has come forward with details.

Changed in chromify-osd:
milestone: 2.2 → 2.3
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers