Comment 33 for bug 1085596

Rune K. Svendsen (runeks) wrote :

glmark2-es2 works under Unity as well, but not without artifacts. I suspect this is because of that bug you mention with the Mali driver and compositing.

This is the output I get when browsing to a YouTube video:

ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
[1704:1704:209401382:ERROR:gl_surface.cc(83)] Not implemented reached in virtual bool gfx::GLSurface::Resize(const gfx::Size&)
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
[1704:1704:212986204:ERROR:gpu_video_decode_accelerator.cc(193)] Not implemented reached in void GpuVideoDecodeAccelerator::Initialize(media::VideoCodecProfile, IPC::Message*)HW video decode acceleration not available.
[WARNING:flash/platform/pepper/pep_videocodec.cpp(722)] Video decoder creation failed.
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream

These messages all seem to be related to playing YouTube videos, as they only appear in the output after opening a YouTube video.

There's a difference between playing different videos on YouTube though. The above output is from playing this video http://www.youtube.com/watch?v=kDsXFIHnVPw
It doesn't even start to play. No audio or video.

This video though http://www.youtube.com/watch?v=WwG9of7EUi0 works, and only gives the output

[1957:1957:373349566:ERROR:gl_surface.cc(83)] Not implemented reached in virtual bool gfx::GLSurface::Resize(const gfx::Size&)

not the "HW video decode acceleration not available." error.