Cross distro support for Samsung Chromebook (ARM based)

Merge Chromebook UCM profiles into ALSA packages

Reported by Marcin Juszkiewicz on 2012-12-01
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Cross distro support for Samsung Chromebook (ARM based)
Critical
Marcin Juszkiewicz
alsa-lib (Fedora)
New
Undecided
Unassigned
alsa-lib (Ubuntu)
Undecided
Unassigned
Precise
High
Unassigned
Quantal
High
Unassigned
alsa-utils (Ubuntu)
Undecided
Unassigned
Precise
High
Unassigned
Quantal
High
Unassigned

Bug Description

SRU test case in comment 13 below
https://bugs.launchpad.net/chromebook-arm/+bug/1085392/comments/13

===

Samsung Chromebook has UCM profiles which handle automatic switching speakers<>headphones (and probably <>hdmi but not checked under Ubuntu yet). We need to ship them to save users from frying speakers.

Marcin Juszkiewicz (hrw) wrote :

Attached debdiff adds Chromebook UCM profiles.

summary: - Ubuntu: merge UCM profiles into alsa-lib
+ Ubuntu: merge Chromebook UCM profiles into alsa-lib
Changed in chromebook-arm:
importance: Undecided → Critical
assignee: nobody → Marcin Juszkiewicz (hrw)
status: New → Triaged

13:42 < infinity> Argh, PandaES was dropped in the last merge AGAIN.
13:42 < hrw> infinity: we may have to do alsa-ucm-profiles package and maintain it in Debian instead of patching alsa-lib?
13:48 < infinity> hrw: Possibly.
13:54 < infinity> hrw: Hrm, you probably also need a new alsa-utils to actually trigger this.
13:55 < infinity> hrw: See /lib/udev/rules.d/90-alsa-ucm.rules
13:55 < hrw> good point. Thanks

summary: - Ubuntu: merge Chromebook UCM profiles into alsa-lib
+ Ubuntu: merge Chromebook UCM profiles into ALSA packages

This bug was fixed in the package alsa-lib - 1.0.25-4ubuntu2

---------------
alsa-lib (1.0.25-4ubuntu2) raring; urgency=low

  [ Marcin Juszkiewicz ]
  * Add Samsung Chromebook UCM configuration - LP: #1085392

  [ Adam Conrad ]
  * Re-introduce PandaES UCM profiles dropped in a previous merge.
 -- Marcin Juszkiewicz <email address hidden> Sat, 01 Dec 2012 13:22:52 +0100

Changed in alsa-lib (Ubuntu):
status: New → Fix Released
Marcin Juszkiewicz (hrw) wrote :

alsa-utils debdiff to add Chromebook support into udev rule

Adam Conrad (adconrad) on 2012-12-01
Changed in alsa-utils (Ubuntu):
status: New → Fix Committed
Marcin Juszkiewicz (hrw) on 2012-12-01
Changed in alsa-utils (Ubuntu):
status: Fix Committed → Fix Released
Marcin Juszkiewicz (hrw) on 2012-12-01
summary: - Ubuntu: merge Chromebook UCM profiles into ALSA packages
+ Merge Chromebook UCM profiles into ALSA packages
Pbrobinson (pbrobinson) wrote :

It should be going upstream into http://git.alsa-project.org/?p=alsa-ucm-conf.git;a=summary along with the PandaES and other UCM configs so there's a central upstream location for them to go.

Marcin Juszkiewicz (hrw) wrote :

alsa-utils SRU for precise to add UCM profiles for Chromebook

Marcin Juszkiewicz (hrw) wrote :

alsa-utils SRU for quantal to add UCM profiles for Chromebook

Marcin Juszkiewicz (hrw) wrote :

alsa-utils SRU for quantal to add UCM profiles for Chromebook

Marcin Juszkiewicz (hrw) wrote :

alsa-lib SRU for precise to add UCM profiles for Chromebook

Marcin Juszkiewicz (hrw) wrote :

alsa-lib SRU for quantal to add UCM profiles for Chromebook

Marcin Juszkiewicz (hrw) wrote :

I request SRU for precise and quantal cause those two releases are often used by Chromebook users. Most popular method of installation gives people 12.04 and some people do update to 12.10.

Changes are merged into 13.04 but most of users prefer not to use development release.

Dimitri John Ledkov (xnox) wrote :

The bug description is lacking SRU information, in particular test-case (preferably the one the does not require frying one's speakers)

Please see bug template here:
https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

Once done, please subscribe ~ubuntu-sponsors team to get this uploaded into proposed queue.

Marcin Juszkiewicz (hrw) wrote :

[Impact]

When Google started selling Samsung Chromebook many people bought them because they are one of fastest ARM machines and have useful formfactor. But due to hardware bug which does not have workaround in kernel there is a possibility to fry speakers in device if you play with ALSA mixer setup. And by default non-Chromium distributions do not give working audio so people (including me) burnt their speakers during trying.

Then we got suggestion to merge UCM profiles from Chromium into our distributions. Once they are in place audio just works. By default audio goes to speakers with automatic switching to headphones when they are plugged and back to speakers when unplugged. HDMI output is probably handled same way but this part I did not tested.

I want to have those profiles in both Precise and Quantal because most popular way of installing Ubuntu on Chromebook is to run ChrUbuntu shell script which gives users 12.04 release. Some of them did upgrade to 12.10 to get more fresh software but small amount of them went to current development release which has this issue fixed already.

[Test Case]

 * detailed instructions how to reproduce the bug

1. Boot Samsung Chromebook (ARM one)
2. Login or use guest session
3. Run terminal (Ctrl+Alt+t)
4. Run “alsamixer -c0″
5. Set “Lineout” to highest value
6. Unmute everything what starts with “Left” or “Right” (depends which speaker you do not like)
7. Touch speakers (but better not for long)
8. Hold “Power” button to shut down before it will burn though your desk.

 * these should allow someone who is not familiar with the affected
   package to reproduce the bug and verify that the updated package fixes
   the problem.

With fixed packages all needed to do is use any application to play audio - no ALSA mixer tweaking required. Procedure shown before will still burn speakers but user does not have to use mixer to get audio working.

[Regression Potential]

Package changes affect only users of Samsung Chromebook devices - they get audio working out of box. Users of other platforms will just get few KB of space used on disk.

[Other Info]

Fix was tested by users of Ubuntu and few other distributions.

description: updated
Changed in alsa-lib (Ubuntu Precise):
status: New → Confirmed
Changed in alsa-lib (Ubuntu Quantal):
status: New → Confirmed
Changed in alsa-utils (Ubuntu Precise):
status: New → Confirmed
Changed in alsa-utils (Ubuntu Quantal):
status: New → Confirmed
Changed in alsa-lib (Ubuntu Precise):
importance: Undecided → High
Changed in alsa-lib (Ubuntu Quantal):
importance: Undecided → High
Changed in alsa-utils (Ubuntu Precise):
importance: Undecided → High
Changed in alsa-utils (Ubuntu Quantal):
importance: Undecided → High
Tom Townsend (tom-towny) wrote :

After updating and verifying that I have the latest versions of alsa-lib and alsa-utils sound still is not working on my Ubuntu 12.10 install.

Has the fix been released? Statuses of 'fixed released' and 'triaged' seem to be contradictory...

Marcin Juszkiewicz (hrw) wrote :

Fixes are released in 'raring' (13.04). For quantal and precise releases we are waiting for someone to sponsor uploads.

Tom Townsend (tom-towny) wrote :

@Marcin : Thanks for the clarification. Hopefully this will be rectified soon as the large majority of people seem to be on non 'raring' builds.

Changed in alsa-lib (Ubuntu Quantal):
status: Confirmed → In Progress
Changed in alsa-utils (Ubuntu Precise):
status: Confirmed → In Progress
Changed in alsa-utils (Ubuntu Quantal):
status: Confirmed → In Progress
Changed in alsa-lib (Ubuntu Precise):
status: Confirmed → In Progress
Dimitri John Ledkov (xnox) wrote :

alsa-utils precise debdiff: missing bug reference
alsa-tuils quantal debdiff: missing bug reference
alsa-lib quantal debdiff: targetted quantal

all debdiffs applied cleanly, so I fixed up above issues.

Successfully uploaded alsa-lib_1.0.25-1ubuntu10.2.dsc to upload.ubuntu.com for ubuntu.
Successfully uploaded alsa-lib_1.0.25-1ubuntu10.2.debian.tar.bz2 to upload.ubuntu.com for ubuntu.
Successfully uploaded alsa-lib_1.0.25-1ubuntu10.2_source.changes to upload.ubuntu.com for ubuntu.
Successfully uploaded alsa-lib_1.0.25-3ubuntu3.1.dsc to upload.ubuntu.com for ubuntu.
Successfully uploaded alsa-lib_1.0.25-3ubuntu3.1.debian.tar.bz2 to upload.ubuntu.com for ubuntu.
Successfully uploaded alsa-lib_1.0.25-3ubuntu3.1_source.changes to upload.ubuntu.com for ubuntu.
Successfully uploaded alsa-utils_1.0.25-1ubuntu5.1.dsc to upload.ubuntu.com for ubuntu.
Successfully uploaded alsa-utils_1.0.25-1ubuntu5.1.debian.tar.bz2 to upload.ubuntu.com for ubuntu.
Successfully uploaded alsa-utils_1.0.25-1ubuntu5.1_source.changes to upload.ubuntu.com for ubuntu.
Successfully uploaded alsa-utils_1.0.25-3ubuntu2.1.dsc to upload.ubuntu.com for ubuntu.
Successfully uploaded alsa-utils_1.0.25-3ubuntu2.1.debian.tar.bz2 to upload.ubuntu.com for ubuntu.
Successfully uploaded alsa-utils_1.0.25-3ubuntu2.1_source.changes to upload.ubuntu.com for ubuntu.

Now these packages will be in unapproved queues and will need a member of SRU team to accept them.

Hello Marcin, or anyone else affected,

Accepted alsa-utils into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/alsa-utils/1.0.25-1ubuntu5.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in alsa-utils (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in alsa-lib (Ubuntu Precise):
status: In Progress → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Marcin, or anyone else affected,

Accepted alsa-lib into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/alsa-lib/1.0.25-1ubuntu10.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in alsa-lib (Ubuntu Quantal):
status: In Progress → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Marcin, or anyone else affected,

Accepted alsa-lib into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/alsa-lib/1.0.25-3ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in alsa-utils (Ubuntu Quantal):
status: In Progress → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Marcin, or anyone else affected,

Accepted alsa-utils into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/alsa-utils/1.0.25-3ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Derek (bugs-m8y) wrote :

So. I enabled proposed for precise, updated, rebooted. No sound. Tried, for heck of it, alsaucm -c DAISY-I2S since one set of instructions for copying the chromebook profiles said to run that after.

Still nothing. I *am* supposed to have sound after this, right?

Marcin Juszkiewicz (hrw) wrote :

Derek: sound should work on speakers, automatically switch to headphones when they are plugged in.

Derek (bugs-m8y) wrote :

Welp. In that case. Just pulled latest updates, rebooted, tried playing audio in a few apps. Nothing. The usual channels seem unmuted in alsamixer - is there one I should look for? I'm worried about melting this thing.

Derek (bugs-m8y) wrote :

Updated again today.
Just checked alsa-utils.
I have 1.0.25-1ubuntu5.1 (precise-proposed)

Still no sound in ubuntu, sound works fine in chromeos

Chris Halse Rogers (raof) wrote :

That looks like a verification-failed to me on precise.

tags: added: verification-failed-precise
Adam Conrad (adconrad) wrote :

The alsa-utils fix depends on the libasound2 (alsa-lib) fix as well, were both packages upgraded when verifying? I might just do a visual verification (ie: make sure all the files are in the right places in the binary packages) and push this through to unstick some other SRUs.

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of alsa-lib from precise-proposed was performed and bug 1172933 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1172933 "bot-stop-nagging". Thanks!

tags: added: verification-failed
Adam Conrad (adconrad) on 2013-05-09
tags: removed: verification-failed
Marcin Juszkiewicz (hrw) wrote :

ii alsa-utils 1.0.25-1ubuntu5.2 Utilities for configuring and using ALSA
ii libasound2 1.0.25-1ubuntu10.2 shared library for ALSA applications

I started "alsaucm -c DAISY-I2S set _verb HiFi" and then "aplay /usr/share/sounds/alsa/Noise.wav" played noise on right speaker of my chromebook (left one is dead).

Marcin Juszkiewicz (hrw) wrote :

Sound works fine on my Chromebook under "precise" straight after reboot.

Marcin Juszkiewicz (hrw) wrote :

Sound was automatically switched headphones<>speakers when needed.

tags: added: verification-passed-precise
removed: verification-failed-precise
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.0.25-1ubuntu10.2

---------------
alsa-lib (1.0.25-1ubuntu10.2) precise-proposed; urgency=low

  * Add Samsung Chromebook UCM configuration - LP: #1085392
 -- Marcin Juszkiewicz <email address hidden> Fri, 14 Dec 2012 19:14:09 +0100

Changed in alsa-lib (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.0.25-3ubuntu3.1

---------------
alsa-lib (1.0.25-3ubuntu3.1) quantal; urgency=low

  * Add Samsung Chromebook UCM configuration - LP: #1085392
 -- Marcin Juszkiewicz <email address hidden> Fri, 14 Dec 2012 19:14:09 +0100

Changed in alsa-lib (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-utils - 1.0.25-3ubuntu2.2

---------------
alsa-utils (1.0.25-3ubuntu2.2) quantal-proposed; urgency=low

  * debian/control: Mark alsa-utils Multi-Arch foreign (LP: #1126633)

alsa-utils (1.0.25-3ubuntu2.1) quantal; urgency=low

  * Added Samsung Chromebook support into 90-alsa-ucm.rules LP: #1085392
 -- Mark Russell <email address hidden> Sat, 02 Mar 2013 12:13:58 -0500

Changed in alsa-utils (Ubuntu Quantal):
status: Fix Committed → Fix Released
Adam Conrad (adconrad) wrote :

Fixed in alsa-utils 1.0.25-1ubuntu5.2 in precise, but the bug closure failed:

----------------
alsa-utils (1.0.25-1ubuntu5.1) precise-proposed; urgency=low

  * Added Samsung Chromebook support into 90-alsa-ucm.rules LP: #1085392
 -- Marcin Juszkiewicz <email address hidden> Fri, 14 Dec 2012 19:17:11 +0100

Changed in alsa-utils (Ubuntu Precise):
status: Fix Committed → Fix Released
Marcin Juszkiewicz (hrw) wrote :

Chromebook UCM profile is part of alsa-lib 1.0.27.1 upstream release. Now it is up to distributions to handle it.

Changed in chromebook-arm:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers