can't assign a user specific privileges

Bug #980869 reported by federico prato on 2012-04-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
chive
Fix Released
Medium
David Roth

Bug Description

When i click on the database icon next to my user to assign him specific privileges on a DB, i receive the error "Ajax request failed"

Related branches

federico prato (federico-prato) wrote :
Philipp Rieber (cztq7ln4t) wrote :

I can confirm this issue and it's very critical for us because all our applications are using a separate user and database and we are used to assign schema specific privileges only.

David Roth (davrot) wrote :

Yes there is a problem when mod_rewrite is disabled (index.php.. is in the address line of the browser) - is this your config?

Changed in chive:
assignee: nobody → David Roth (davrot)
importance: Undecided → Medium
milestone: none → 1.0.4
status: New → Confirmed
federico prato (federico-prato) wrote :

not really... my server has mod_rewrite enabled. Here's my phpinfo. thanks!

David Roth (davrot) wrote :

Is chive really running with url rewriting (allow_override enabled?). You can also see this if you finde "index.php" in the browser url?

federico prato (federico-prato) wrote :

oh, you're right. when i go to subpages i have index.php in the url. What should i do to make it disappear? in the chive directory i have the .htaccess file chive provides... and on the server i never had problems with mod rewrite (i have many drupal websites with clean urls enabled).
thanks

David Roth (davrot) wrote :

You usually have to enable the allow_override directive in the /etc/apache2/sites-enabled/000-default config. (just an example on a debian based machine).

On my machine it looks like this:

<Directory /var/www/chive/trunk/>
AllowOverride All
</Directory>

Anyway, good to know that its related to the rewriting, so we will fix this for 1.0.4.
As already mentioned, you can resolve this with the Allow-Override setting until I have provided a fix.

David Roth (davrot) on 2012-06-08
Changed in chive:
milestone: 1.0.4 → 1.1
David Roth (davrot) on 2012-06-08
Changed in chive:
status: Confirmed → Fix Committed
David Roth (davrot) on 2012-06-17
Changed in chive:
status: Fix Committed → Fix Released
milestone: 1.1 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers