suspend/suspend_advanced should not depend on bluetooth/detect-output

Bug #955375 reported by Daniel Manrique on 2012-03-14
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Checkbox
High
Jeff Lane

Bug Description

Checkbox 0.13.4 on Precise (beta 1).

At least one of the dependencies for suspend/suspend_advanced is wrong:

depends: power-management/rtc suspend/network_before_suspend
suspend/resolution_before_suspend suspend/wireless_before_suspend
bluetooth/detect-output suspend/cpu_before_suspend
suspend/memory_before_suspend

if bluetooth/detect-output is not run (on a system without bluetooth it won't run because requirements aren't met), then suspend_advanced will also fail to run. Thus, we're not testing suspend behavior on systems without bluetooth support, which makes little sense :)

Related branches

Jeff Lane (bladernr) on 2012-03-14
Changed in checkbox:
status: New → Confirmed
milestone: none → 0.13.5
importance: Undecided → High
Jeff Lane (bladernr) wrote :

Yep... I am pretty sure this is left over from before we excluded bluetooth_detect on systems without bluetooth. So this should be changed to reflect how the tests work now.

Since this was a trivial removal, I just pushed it through.

Changed in checkbox:
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
assignee: nobody → Jeff Lane (bladernr)
Daniel Manrique (roadmr) wrote :

Thanks!

As a comment, since checkbox now runs jobs in the order specified in the whitelist, if we ever need to run jobs in a certain order but don't want them to depend on each other (so later jobs still run if the earlier ones fail) this can be done by specifying them in the correct order in the whitelist.

Cheers!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers