[checkbox-qt] test doesn't select Yes on pass

Bug #954556 reported by Jeff Lane on 2012-03-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
Low
Sylvain Pineau

Bug Description

Discovered this while testing a fix for another issue. When I ran a test, the instructions said that Yes would automatically be selected on successful completion of the test. However, it did not.

Steps to reproduce:
run checkbox-qt from 0.13.5 trunk
deselect all tests but keys/media-control
run tests
when media-control test opens, click Test to continue
perform test on rev, play/pause and ff buttons.
Click skip on the stop button

Expected Results: YES is highlighted indicating the test passed

Actual Results: TEST is highlighted and clicking next brings up a warning that I'm skipping an entire test.

It may be related to me clicking the Skip button for the "Stop" button test. However, that was necessary because the system I tested this on does not have a stop button, it only has REW, FF and Play/Pause.

Related branches

Ara Pulido (ara) on 2012-03-15
Changed in checkbox:
milestone: none → 0.13.5
Changed in checkbox:
assignee: nobody → Sylvain Pineau (sylvain-pineau)
importance: Undecided → Low
status: New → In Progress
Daniel Manrique (roadmr) on 2012-03-20
Changed in checkbox:
status: In Progress → Fix Committed
Ara Pulido (ara) on 2012-03-22
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers