keys/media_keys test doesn't run

Bug #954480 reported by Daniel Manrique on 2012-03-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
Medium
Daniel Manrique

Bug Description

Checkbox 0.13.4.

How to reproduce:

- Start checkbox-qt
- Deselect all tests
- Select only Hotkeys -> keys/media-control
- click "Start testing"

Expected result:
- Media-control test runs (it's interactive)

Actual result:
- Test doesn't run (I go straight to report generation)
- This trace in the logfile:

2012-03-13 17:32:31,280 ERROR Error running event handler ./plugins/manual_test.py ManualTest.prompt_manual(<checkbox_qt.qt_interface.QTInterface ob
ject at 0x2c83a50>, {'status': 'uninitiated', 'description': u'PURPOSE:\n This test will test the media keys of your keyboard\nSTEPS:\n 1. Click
test to open a window on which to test the media control keys.\n 2. If all the keys work, the test will be marked as passed.\n 3. If your compute
r has no media control keys, Skip this test.\n VERIFICATION:\n Do the keys work as expected?', 'plugi
n': 'manual', 'requires': ["device.category == 'KEYBOARD'"], 'sortkey': 6, 'command': 'media_keys_test', 'suite': '__keys__', 'type': 'test', 'resources': [{'category': 'KEYBOARD', 'product': 'AT Translated Set 2 keyboard', 'bus': 'input', 'driver': 'atkbd', 'sortkey': 69, 'path': '/devices/platform/i8042/serio0/input/input4'}], 'name': 'keys/media-control'}) for event type 'prompt-manual'
Traceback (most recent call last):
  File "/home/roadmr/Documents/checkboxes/fix-media-keys/checkbox/reactor.py", line 74, in fire
    results.append(handler(*args, **kwargs))
  File "./plugins/manual_test.py", line 41, in prompt_manual
    interface.show_test(test, runner)
  File "/home/roadmr/Documents/checkboxes/fix-media-keys/checkbox_qt/qt_interface.py", line 200, in show_test
    if test["info"] and "$output" in test["info"]:
KeyError: 'info'

The problem is that the jobs/keys.txt.in file has an indentation error in the media-keys job definition.

Related branches

Daniel Manrique (roadmr) on 2012-03-13
Changed in checkbox:
status: New → In Progress
assignee: nobody → Daniel Manrique (roadmr)
importance: Undecided → Medium
milestone: none → 0.13.5
Daniel Manrique (roadmr) on 2012-03-20
Changed in checkbox:
status: In Progress → Fix Committed
Ara Pulido (ara) on 2012-03-22
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers