[Checkbox Qt] the automatic tests status are not correctly updated

Bug #950105 reported by Tiago Salem Herrmann on 2012-03-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
Medium
Tiago Salem Herrmann

Bug Description

The status of tests executed automatically by the backend are not correctly updated on the Qt UI.

Related branches

Daniel Manrique (roadmr) on 2012-03-12
Changed in checkbox:
status: New → In Progress
assignee: nobody → Tiago Salem Herrmann (tiagosh)
importance: Undecided → Medium
milestone: none → 0.13.5
Daniel Manrique (roadmr) wrote :

This is present in Checkbox-qt 0.13.4.

TEST CASE (or, Steps to Reproduce):
- Use a system that has a working bluetooth adapter.
- Start checkbox-qt.
- Right-click on the test selection list, deselect all
- Select only the Miscellaneous, Bluetooth, Informational and Keys categories.
- Click on Start Testing
- Wait until prompted for a manual test (should be keys/volume)
- Click on the "Selection" tab

Expected result:
- Automated tests that were already run are marked as Done. In this case, the Bluetooth/detect test automatically ran, yet is marked as "Not Started".

Actual result:
In this case, the Bluetooth/detect test automatically ran, yet is marked as "Not Started".

Daniel Manrique (roadmr) on 2012-03-12
tags: added: testcase
Daniel Manrique (roadmr) on 2012-03-12
Changed in checkbox:
status: In Progress → Fix Committed
Ara Pulido (ara) on 2012-03-22
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers