checkbox always asserts wireless connection error on no wireless system

Bug #907150 reported by TienFu Chen
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
Fix Released
Medium
TienFu Chen
Nominated for 0.12 by Jeff Lane

Bug Description

checkbox 0.12.11~ppa0.11.10
checkbox-certification 0.12.11~ppa28.11.10
checkbox-certification-client 0.12.11~ppa28.11.10
checkbox-gtk 0.12.11~ppa0.11.10
-------------------------------
suspend/wireless_after_suspend __suspend__ Fail Error: Unknown connection: .
suspend/wireless_before_suspend __suspend__ Fail Error: Unknown connection: .

ref: https://certification.canonical.com/hardware/201112-10227/submission/8M3E1Ke6RtPwvHJ/results?form.status=FAIL&form.status=UNRESOLVED

Related branches

Revision history for this message
TienFu Chen (ctf) wrote :
Revision history for this message
Brendan Donegan (brendan-donegan) wrote :

This test is in checkbox, so moving to that package. To confirm this, Tim do you mean to say this tests runs on systems that don't have a wireless card?

affects: checkbox-certification → checkbox
visibility: private → public
Revision history for this message
Ara Pulido (ara) wrote :

Yes, that's what he means

TienFu Chen (ctf)
Changed in checkbox:
assignee: nobody → Tim Chen (ctf)
Revision history for this message
TienFu Chen (ctf) wrote :

this bug is caused by the bug, https://bugs.launchpad.net/checkbox/+bug/912204
The wireless_after_suspend and wireless_before_suspend depend on wireless/wireless_connection,
But the "requires" in jobs files doesn't work, so wireless/wireless_connection is always executed on system without wireless module.

Revision history for this message
Jeff Lane (bladernr) wrote :

Nope... the requires directive is honored properly, it's the depends directive that's the problem. Since the depends is ignored, even though wireless/wireless_connection doesn't run the wireless tests themselves are run.

So basically, it looks like this is happening:

wireless/wireless_connection is skipped because "requires: device.category == 'WIRELESS'" is not met.
suspend/wireless_before_suspend is run because "depends: wireless/wireless_connection" is ignored

A possible solution would be to add:

requires: device.category == 'WIRELESS'

to all wireless testing jobs... this would work around the depends issue and hopefully ensure that the tests are not run if wireless is not found.

Still doesn't resolve the issue of what to do if the parent (wireless/wireless_connection) fails, but at least that should prevent the tests from running otherwise.

Revision history for this message
Jeff Lane (bladernr) wrote :

Merge proposed that should work around this...

Also, I hope I got the nominate thing right... never used it before, but this needs to be backported to 0.12 as a bug fix at some point.

Changed in checkbox:
status: New → Fix Committed
importance: Undecided → Medium
Marc Tardif (cr3)
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers