[checkbox-cli] CLI after a certain number of test items in the test list, checkbox assigns the SPACE bar to a test item, this makes the CLI unusable

Bug #877467 reported by Jeff Lane
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Checkbox
Fix Released
High
Brendan Donegan

Bug Description

I noticed the other day that if you run checkbox-cli with a long enough whitelist (I think certification.whitelist has enough tests to show this) checkbox will assign keys to each test. During test selection, the user is prompted to it a key to enable or disable a test. The problem is, given enough of a list, checkbox eventually assigns a ' ' (space) as the key for a test in the list. ' ' (space) is also the key dedicated to "Continue" on the test list.

So, given a long enough list of tests, the ' ' will be used for a test case AND continue, and there is then no way to actually move beyond the test selection part and into actual testing.

Related branches

Revision history for this message
Brendan Donegan (brendan-donegan) wrote :

checkbox-cli isn't usable at all for ubuntu-friendly without this so I'll try and propose a fix asap.

Changed in checkbox:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Brendan Donegan (brendan-donegan)
status: Triaged → In Progress
Revision history for this message
Brendan Donegan (brendan-donegan) wrote :

Basically, the function which chooses a key for the option needs to be more robust - it currently chooses the first character which is either in the name of the option (e.g. 'USB tests') or the the set of lowercase letters a-z

It shouldn't be allowed to choose space or + as these have other meanings in the UI, and it also should be allowed to use more than just lowercase letters (numbers, punctuation) or else it will run out of options quickly.

In this particular case, USB Tests was being assigned space because there is a space in it and 'u', 's' and 'b' had already been used.

Changed in checkbox:
status: In Progress → Fix Committed
milestone: none → 0.13
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers