[keys/*] most of the keys tests are skipped because of the requires

Bug #875312 reported by Jeff Lane
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
Fix Released
High
Marc Tardif

Bug Description

Checkbox is skipping most of the keys tests because they all have the line:

requires = device.product in ['Noteook','Laptop','Portable']

and unfortunately, all of the systems I've tested so far (some Eee PCs, Dells and Lenovos) are not returning device.product in that list, so most of the keys tests are being skipped during the certification runs.

Related branches

Revision history for this message
Brendan Donegan (brendan-donegan) wrote :

Hi Jeff,

During the Alpha3 testing there was a bug reported that stated that we should add the 'Portable' product to the requires. It seems this still isn't sufficient. Are the systems in question not returning anything for device.product? Or are they, but it's just not in that list?

Changed in checkbox:
status: New → Incomplete
importance: Undecided → High
Revision history for this message
Marc Tardif (cr3) wrote :

The problem is related to my latest changes to consistently report devices both online and offline, sorry about that. The changes require specifying dmi.product instead of device.product because not enough dmi information is provided in the output of udevadm itself. Instead, we need to rely on the output of the dmidecode command hence the different namespace. I have pushed the changes to trunk, backported to the 0.12 series and a new package is currently building in the hardware-certification PPA. Thanks for the bug report, it was very clear what needed fixing!

Changed in checkbox:
assignee: nobody → Marc Tardif (cr3)
status: Incomplete → Fix Released
Revision history for this message
Marc Tardif (cr3) wrote :

For your reassurance, this did not affect the package in Oneiric, only the package in the hardware-certification PPA.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers