Dependencies are not always being honoured

Bug #861218 reported by Ara Pulido on 2011-09-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
High
Marc Tardif

Bug Description

Steps to reproduce:

- Launch checkbox, this works even from trunk source. If running from trunk, use:
bin/checkbox-gtk -W data/whitelists/default.whitelist
- On the test selection screen, deselect everything, and select only:
   - keys/sleep under Hotkey tests
   - suspend/suspend_advanced under Suspend tests
- Continue the test run

- Expected result:
 1- suspend/suspend_advanced runs *before* keys/sleep
 2- If suspend_advanced is marked as fail, keys/sleep doesn't run

- Actual result:
- keys/sleep runs first
- I never managed to get them to run in correct order, so I could check what happens if suspend_advanced fails.

Related branches

Daniel Manrique (roadmr) wrote :

As of revision 1021 of checkbox, the keys/sleep job contains the required dependency on suspend/suspend_advanced:

plugin: manual
name: keys/sleep
requires: device.product in ['Notebook','Laptop','Portable']
depends: suspend/suspend_advanced
_description:
 Press the sleep key on the keyboard. The computer should suspend and, \
 after pressing the power button, resume successfully.
 .
 Does the key work?

I'll try to confirm and see why it's not working as intended.

Daniel Manrique (roadmr) wrote :

OK, confirmed, even with the dependency in place and using checkbox trunk as of 20110928.

Steps to reproduce:

- Launch checkbox, this works even from trunk source. If running from trunk, use:
bin/checkbox-gtk -W data/whitelists/default.whitelist
- On the test selection screen, deselect everything, and select only:
   - keys/sleep under Hotkey tests
   - suspend/suspend_advanced under Suspend tests
- Continue the test run

- Expected result:
 1- suspend/suspend_advanced runs *before* keys/sleep
 2- If suspend_advanced is marked as fail, keys/sleep doesn't run

- Actual result:
- keys/sleep runs first
- I never managed to get them to run in correct order, so I could check what happens if suspend_advanced fails.

Changed in checkbox:
status: New → Confirmed

I'm afraid this is yet another example of dependencies being borked - we're lucky that even the suspend tests seem to run in the correct order. I'm looking at this under the pretense of another bug but it would probably be best if we all worked under one bug instead of putting our findings in different places.

Ara Pulido (ara) on 2011-09-28
summary: - Sleep key test should depend on suspend test
+ Dependencies are not always being honoured
description: updated
Jeff Lane (bladernr) wrote :

Marc's merge seems to resolve this. Tested using the mediacard tests and suspend-resume and verified that _after_suspend tests are now running after suspend rather than before (during their own suite's run)

Changed in checkbox:
status: Confirmed → Fix Committed
assignee: nobody → Marc Tardif (cr3)
Ara Pulido (ara) on 2011-09-30
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers