[suspend/wireless_*_suspend]Tests fail even though wireless is working

Bug #855845 reported by Jeff Lane on 2011-09-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
High
Jeff Lane
checkbox (Ubuntu)
Undecided
Unassigned

Bug Description

Ran checkbox and noticed that both wireless_before_suspend and wireless_after_suspend failed. These are failing with the following error message in the test report:

Error: Device 'eth0' (/org/freedesktop/NetworkManager/Devices/0) disconnecting failed: This device is not active
Error: Connection activation failed: Device not managed by NetworkManager or unavailable

eth0 is not a wireless card at all, but my onboard copper card. My wireless card is listed as wlan0. There's no reason why this test should be trying to touch my copper card. Wireless works fine before and after suspend, but the test is a false failure because the copper card is not connected to anything.

Related branches

Jeff Lane (bladernr) on 2011-09-21
Changed in checkbox:
importance: Undecided → High
milestone: none → 0.12.8

I've noticed this can fail when it tries to use the 'wrong' connection. Since I wrote the connect_wireless script let's have a` go debugging it when you're online tomorrow.

Changed in checkbox:
status: New → Confirmed
assignee: nobody → Brendan Donegan (brendan-donegan)

I get almost the same message on my system:

Error: Device 'eth0' (/org/freedesktop/NetworkManager/Devices/0) disconnecting failed: This device is not active

but not the second part.

What the test is actually doing is:

Disconnecting ALL active connections (including ethernet) and then connecting to a wireless connection that should work (the criteria here is either the currently active wireless connection or if the wireless connection isn't active then the last used one)

It then tries a network test to see if everything's okay.

I guess the script could forgo disconnecting devices which aren't actively connected, but I found it wasn't necessary when developing the script. Let's do a bit more debugging and find out exactly what's going wrong.

Changed in checkbox:
status: Confirmed → In Progress
Changed in checkbox:
assignee: Brendan Donegan (brendan-donegan) → Jeff Lane (bladernr)
Jeff Lane (bladernr) on 2011-09-22
Changed in checkbox:
status: In Progress → Fix Committed
Ara Pulido (ara) on 2011-09-23
Changed in checkbox (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.12.8

---------------
checkbox (0.12.8) oneiric; urgency=low

  New upstream release (LP: #862579):

  [Brendan Donegan]
  * Remove test for FTP connection from network_check script (LP: #854222)
  * Update a parameter in usb_test to have it run faster.
  * Remove record_playback_after_suspend from Ubuntu Friendly whitelist (LP: #855540)
  * Fix minor typo in multi-monitor friendly resolution_test script which caused
    minimum_resolution test to fail (LP: #855599)
  * Remove storage_devices_test from Ubuntu Friendly whitelist since bonnie++ (which it uses) is not installed by default (LP: #855841)
  * Changed description and name to reflect Ubuntu Friendly branding. Now when a user searches for Ubuntu Friendly in the lens, Checkbox will appear (LP: #852036)
  * Reset the selections at the test suite prompt if No is selected at the recover prompt (LP: #861208)
  * Save the connection name(s) instead of the interface name so that they can be reconnected to properly after the wireless before/after suspend tests have completed (LP: #861502)
  * Make connect_wireless use the UUID of the connection instead of the name for greater reliability (LP: #862190)

  [Daniel Manrique]
  * Restored _recover attribute, re-enabling welcome and test selection
    screens (LP: #852204)
  * Remove memory/test from the Ubuntu Friendly whitelist (LP: #853799)
  * Use diff instead of grep, better comparing of empty files (LP: #852014)
  * Apport integration: new mandatory "tag" value in ApportOptions (LP: #852201)
  * Add warning prior to starting the tests (LP: #855328)
  * Apport integration: Fix instantiation of Gtk.RadioButton, needed due
    to PyGI related API changes (LP: #805679)
  * Remove ping -R parameter that apparently caused ICMP packets to be dropped
    by some routers (LP: #861404)

  [ Evan Broder ]
  * Replace resolution_test with an implementation which uses GdkScreen to
    be multimonitor-aware (LP: #632987)

  [Jeff Lane]
  * Fix names of optical drive tests and remove a non-existing test from the
    whitelist (LP: #854808)
  * Fix wireless_*_suspend jobs so they recreate iface file instead of append
    each time (LP: #855845)
    (LP: #852201)
  * Clarify better the intend of the is_laptop question (LP: #861844)
  * Fixed dependencies for tests that depend on suspend/suspend_advanced
    (LP: #860651)

  [Tim Chen]
  * Fix cpu_scaling_test (LP: #811177)

  [Ara Pulido]
  * Avoid connect_wireless messing with AP with similar names (LP: #861538)
  * Remove bluetooth/file-transfer from the list of tests to run, since due to
    bug 834348 it always fails.

  [Marc Tardif]
  * Added support for wildcards when verifying the transport certificate.
  * Applying depends across suites (LP: #861218)
 -- Daniel Manrique <email address hidden> Thu, 29 Sep 2011 13:12:01 -0400

Changed in checkbox (Ubuntu):
status: Triaged → Fix Released
Ara Pulido (ara) on 2011-09-30
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers