remove memory test from ubuntu friendly whitelist (default)

Bug #853799 reported by Victor Tuson Palau
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
Fix Released
Critical
Jeff Lane
Ubuntu Friendly
Critical
Jeff Lane
checkbox (Ubuntu)
Critical
Unassigned

Bug Description

multiple users a reporting issues with this test, it seems to doing some kind of memory stress testing that is not required for UF

Related branches

Changed in checkbox:
importance: Undecided → Critical
status: New → Confirmed
Revision history for this message
Brendan Donegan (brendan-donegan) wrote :

So what this test does is it allocates more than free memory (thus forcing swap to be used) for 60 seconds then just free memory for 15 mins. I can't think of a good reason why the second load needs to be run at all unless for performance/load testing purposes. I suggest we change the memory/check test to just do the first part and then create a seperate memory/stress test that can run for as long as we want.

Revision history for this message
Victor Tuson Palau (vtuson) wrote :

I would think that is a good long term solution.

I think for the moment we should just remove the test from the default white list, do as you suggest and then put it back. I am concern that the full fix might be too much churn for Oneiric at this point in the release

Changed in checkbox:
milestone: none → 0.12.8
Revision history for this message
Ara Pulido (ara) wrote :

Let's remove from the whitelist first.

Brendan, can you create another bug for your long term solution?

Changed in checkbox:
assignee: nobody → Canonical Hardware Certification (canonical-hw-cert)
Jeff Lane (bladernr)
Changed in checkbox:
assignee: Canonical Hardware Certification (canonical-hw-cert) → Jeff Lane (bladernr)
Jeff Lane (bladernr)
Changed in checkbox:
status: Confirmed → Fix Committed
Ara Pulido (ara)
Changed in checkbox (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
Jeff Lane (bladernr)
Changed in ubuntu-friendly:
status: New → Fix Committed
assignee: nobody → Jeff Lane (bladernr)
importance: Undecided → Critical
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.12.8

---------------
checkbox (0.12.8) oneiric; urgency=low

  New upstream release (LP: #862579):

  [Brendan Donegan]
  * Remove test for FTP connection from network_check script (LP: #854222)
  * Update a parameter in usb_test to have it run faster.
  * Remove record_playback_after_suspend from Ubuntu Friendly whitelist (LP: #855540)
  * Fix minor typo in multi-monitor friendly resolution_test script which caused
    minimum_resolution test to fail (LP: #855599)
  * Remove storage_devices_test from Ubuntu Friendly whitelist since bonnie++ (which it uses) is not installed by default (LP: #855841)
  * Changed description and name to reflect Ubuntu Friendly branding. Now when a user searches for Ubuntu Friendly in the lens, Checkbox will appear (LP: #852036)
  * Reset the selections at the test suite prompt if No is selected at the recover prompt (LP: #861208)
  * Save the connection name(s) instead of the interface name so that they can be reconnected to properly after the wireless before/after suspend tests have completed (LP: #861502)
  * Make connect_wireless use the UUID of the connection instead of the name for greater reliability (LP: #862190)

  [Daniel Manrique]
  * Restored _recover attribute, re-enabling welcome and test selection
    screens (LP: #852204)
  * Remove memory/test from the Ubuntu Friendly whitelist (LP: #853799)
  * Use diff instead of grep, better comparing of empty files (LP: #852014)
  * Apport integration: new mandatory "tag" value in ApportOptions (LP: #852201)
  * Add warning prior to starting the tests (LP: #855328)
  * Apport integration: Fix instantiation of Gtk.RadioButton, needed due
    to PyGI related API changes (LP: #805679)
  * Remove ping -R parameter that apparently caused ICMP packets to be dropped
    by some routers (LP: #861404)

  [ Evan Broder ]
  * Replace resolution_test with an implementation which uses GdkScreen to
    be multimonitor-aware (LP: #632987)

  [Jeff Lane]
  * Fix names of optical drive tests and remove a non-existing test from the
    whitelist (LP: #854808)
  * Fix wireless_*_suspend jobs so they recreate iface file instead of append
    each time (LP: #855845)
    (LP: #852201)
  * Clarify better the intend of the is_laptop question (LP: #861844)
  * Fixed dependencies for tests that depend on suspend/suspend_advanced
    (LP: #860651)

  [Tim Chen]
  * Fix cpu_scaling_test (LP: #811177)

  [Ara Pulido]
  * Avoid connect_wireless messing with AP with similar names (LP: #861538)
  * Remove bluetooth/file-transfer from the list of tests to run, since due to
    bug 834348 it always fails.

  [Marc Tardif]
  * Added support for wildcards when verifying the transport certificate.
  * Applying depends across suites (LP: #861218)
 -- Daniel Manrique <email address hidden> Thu, 29 Sep 2011 13:12:01 -0400

Changed in checkbox (Ubuntu):
status: Triaged → Fix Released
Ara Pulido (ara)
Changed in checkbox:
status: Fix Committed → Fix Released
Changed in ubuntu-friendly:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers