bug reporting fails (apport integration broken)

Bug #852201 reported by Daniel Manrique on 2011-09-16
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Checkbox
High
Daniel Manrique

Bug Description

Steps to reproduce:

- run checkbox-gtk
- Select all tests
- When the first test comes up, select "No" to mark it as failed and press "Next".
- When prompted to report a bug, say "Yes".

Expected result:
- A bug report filed to launchpad.net

Actual result:
- Nothing appears to happen, checkbox shows the next test in the sequence, and this trace appears in the log file:

2011-09-16 17:17:30,244 ERROR Error running event handler /usr/share/checkbox/plugins/apport_prompt.py ApportPrompt.prompt_test(<checkbox_gtk.gtk_interface.GTKInterface object at 0x2acafd0>, {'status': 'fail', 'description': u'Select Test to play a sound on the automatically detected playback device.\n\nDid you hear a sound and was that sound free of any distortion, clicks or other strange noises?', 'plugin': 'manual', 'requires': ["device.category == 'AUDIO'", "package.name == 'alsa-base' and package.name == 'python-gst0.10'"], 'data': '', 'depends': ['audio/list_devices'], 'command': "gst_pipeline_test -t 2 'audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink'", 'suite': '__audio__', 'type': 'test', 'resources': [{'category': 'AUDIO', 'subproduct_id': '0', 'product_id': '9237', 'bus': 'pci', 'vendor_id': '32902', 'driver': 'Intel ICH', 'path': '/devices/pci0000:00/0000:00:05.0', 'subvendor_id': '32902'}, {'status': 'Installed', 'desired': 'Install', 'version': '1.0.24+dfsg-0ubuntu2', 'name': 'alsa-base', 'description': 'ALSA driver configuration files'}, {'status': 'Installed', 'desired': 'Install', 'version': '0.10.21-2ubuntu1', 'name': 'python-gst0.10', 'description': 'generic media-playing framework (Python bindings)'}], 'name': 'audio/playback_auto'}) for event type 'prompt-test'
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/checkbox/reactor.py", line 74, in fire
    results.append(handler(*args, **kwargs))
  File "/usr/share/checkbox/plugins/apport_prompt.py", line 253, in prompt_test
    apport_interface.run_report_bug()
  File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 391, in run_report_bug
    self.add_extra_tags()
  File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 1099, in add_extra_tags
    if self.options.tag:
AttributeError: 'ApportOptions' object has no attribute 'tag'

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: checkbox 0.12.7
ProcVersionSignature: Ubuntu 3.0.0-11.17-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Fri Sep 16 17:19:15 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110824)
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: checkbox
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Daniel Manrique (roadmr) wrote :
affects: checkbox (Ubuntu) → checkbox
Daniel Manrique (roadmr) wrote :

Triaged due to the fact that we have both a trace and at least one duplicate, with importance: High, bug reporting functionality is important for checkbox as a testing tool.

Also see bug 805679 for another apport-related problem.

Changed in checkbox:
status: New → Triaged
importance: Undecided → High
Daniel Manrique (roadmr) on 2011-09-23
Changed in checkbox:
status: Triaged → In Progress
assignee: nobody → Daniel Manrique (roadmr)
Changed in checkbox:
status: In Progress → Fix Committed
Daniel Manrique (roadmr) on 2011-11-25
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers