Checkbox incorrect wording on creating document test

Bug #821141 reported by Andrew 'Laice' Faulkner on 2011-08-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
Low
Unassigned

Bug Description

Currently Checkbox asks the user to select "Create Document -> Empty File", which as of 11.10a2 is incorrect as the submenu now reads "Create Document -> Empty Document"

Related branches

Andrew 'Laice' Faulkner (laice) wrote :

I have never made any modifications to an open source file before, so i have absolutely no idea if i'm doing the right thing here! please let me know if i'm misguided to do this or misguided in the way i have done it!

Attached is a patched checkbox/user_apps.txt.in with the correct wording.

Kind Regards

Andrew 'Laice' Faulkner (laice) wrote :

Ok so having researched "patches" a bit further it's not a patch, more a modified version of a complete file. Sorry if i'm being a bit nooby.

Daniel Manrique (roadmr) on 2011-08-04
Changed in checkbox:
status: New → Confirmed
importance: Undecided → Low
Daniel Manrique (roadmr) wrote :

Hi Andrew,

Thanks so much for reporting this bug and helping improve Checkbox and Ubuntu!

I have confirmed this bug report on an Oneiric box running Alpha 3. The troublesome text is still present in the latest development code for Checkbox.

The file you sent is fine in principle, however, since the code is under development, I see that a lot of the job descriptions have changed, thus, it's not possible to simply replace the current file with the one you sent.

So, since you mention that you did some research on producing patches, I was wondering if you'd like to take this as a learning opportunity. You could produce a patch that includes *only* the changed portion of the file using the diff command. Assume user_apps.txt.in.old is the original, flawed version and user_apps.txt.in.new is your fixed version. Then do this to generate a patch:

diff -u user_apps.txt.in.old user_apps.txt.in.new > user_apps.txt.in.patch

And attach the .patch file to the bug report. This will be easier for us to integrate into the Checkbox job files.

As an aside, if you'd like to learn more about how we collaborate developing Checkbox, among other open-source projects, the development code for checkbox is managed using the Bazaar version control tool. If you want to learn about Bazaar you can start here:

http://bazaar.canonical.com/en/

Thanks again for your contribution, please don't forget to let me know if producing/attaching the patch worked or if you have trouble doing it!

Regards,
- Daniel

Andrew 'Laice' Faulkner (laice) wrote :

Right well here goes my first ever attempt heh
Rather heartwarming to know that this would be released to most ubuntu desktop editions.

Patch attached.

I thank you for your courteous response and allowing me to develop my skills, i do hope i can use them to more benefit to the community that this little niggle of a patch!

Although probably better for one to start small like this :)

Let me know if everythings OK.

Kind Regards

Daniel Manrique (roadmr) wrote :

Hi Andrew,

Thanks so much for preparing the patch, it was a lot easier to integrate this way.

And thanks for your contribution! This change has been integrated into the latest checkbox development code and, barring unforeseen circumstances, will be included in Checkbox when 11.10 is released.

Changed in checkbox:
status: Confirmed → Fix Committed
Ara Pulido (ara) on 2011-08-25
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers