checkbox spits out confusing traces about 'too many values to unpack'

Bug #796508 reported by Brendan Donegan on 2011-06-13
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Checkbox
Low
Brendan Donegan

Bug Description

When running checkbox-gtk from the command line the following traces are seen when moving the pointer over the main window:

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/checkbox_gtk/hyper_text_view.py", line 78, in _motion
    x, y, _ = window.get_pointer()
ValueError: too many values to unpack

(they'll repeat as long as the pointer is in the window)

These seem like a harmless Python error but it's confusing to have them there if they don't need to be.

The attached branch proposes a simple solution to hiding them (essentially the problem is that get_pointer is now returning a 4-value tuple and the code is only offering a 3-value tuple to unpack it into.

Related branches

Changed in checkbox:
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Brendan Donegan (brendan-donegan)
Changed in checkbox:
status: In Progress → Fix Committed
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers