[CD write test] test tells me that the drive supports writing but it does not actually do so

Bug #772794 reported by Jeff Lane
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
Fix Released
Medium
Jeff Lane

Bug Description

Found during cert testing on the E4310 (201103-7973). That system has a DVD-ROM, but the CD Write test thinks it will actually write to media. It will not.

This is because the test cdrom-write in optical.txt says generically that the detected device will write. It depends on the "optical" test.

"optical" runs the "optical_detect" script which does nothing to determine if a device supports reading or writing. It simply outputs the name of the optical device.

Related branches

Revision history for this message
Ara Pulido (ara) wrote :

Moving to checkbox

affects: checkbox-compatibility → checkbox
Changed in checkbox:
importance: Undecided → Medium
tags: added: test
Revision history for this message
Jeff Lane (bladernr) wrote :

No reason for this to be private...

visibility: private → public
Revision history for this message
Daniel Manrique (roadmr) wrote :

Does this system NOT write to media because the drive is faulty (i.e. it *should* be able to but is not working correctly), or because it's a read-only unit?

Would it be possible to run wodim -prcap /dev/cdrom >/tmp/drive-capabilities.txt (or whatever device this is on) and attach the produced txt file here? This seems to produce quite reliable information on a drive's capabilities, so the test can potentially be amended to use this.

here's partial output from a DVD-ROM (i.e. read-only) drive:

Drive capabilities, per MMC page 2A:

  Does read CD-R media
  Does not write CD-R media
  Does read CD-RW media
  Does not write CD-RW media
  Does read DVD-ROM media
  Does read DVD-R media
  Does not write DVD-R media
  Does read DVD-RAM media
  Does not write DVD-RAM media
  Does not support test writing

Compare to a DVD-RW capable drive:

Drive capabilities, per MMC-3 page 2A:

  Does read CD-R media
  Does write CD-R media
  Does read CD-RW media
  Does write CD-RW media
  Does read DVD-ROM media
  Does read DVD-R media
  Does write DVD-R media
  Does read DVD-RAM media
  Does write DVD-RAM media
  Does support test writing

I don't have a cd-rw-only unit handy, but wodim's output seems to be rather reliable for this.

I'll mark as triaged as hopefully, and pending confirmation on the E4310's results, this is enough information to start working on fixing this test.

Changed in checkbox:
status: New → Triaged
tags: added: checkbox-testsuite
Revision history for this message
Jeff Lane (bladernr) wrote :

The problem is/was in the job description itself. This is a manual test and the original description: field literally said "Your drive supports writing, please put a blank disk in and write to it"

Or something of that nature.

I cleaned that up later on with the UI rewrite stuff. The CD and DVD write tests now say:

PURPOSE:
     This test will check your DVD writing capabilities
 STEPS:
     1. Enter a blank DVD into your drive
     2. Write something in the DVD
     3. Read the newly written DVD
 VERIFICATION:
     Was the data correctly written?

We should still, perhaps ammend those to say something like:

"This test will check your [CD,DVD] writing capabilities. If your optical drive does not support writing [CD,DVD] media, please skip this test."

Jeff Lane (bladernr)
Changed in checkbox:
assignee: nobody → Jeff Lane (bladernr)
status: Triaged → In Progress
Revision history for this message
Jeff Lane (bladernr) wrote :

Fix has been merged. The strings now say:

This test will check your system's [CD,DVD] writing capabilities. If your drive does not support writing [CD,DVD]s or you do not have any blank [CD,DVD] media, please skip this test.

Changed in checkbox:
status: In Progress → Fix Committed
Daniel Manrique (roadmr)
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers