udevadm not found

Bug #597305 reported by Javier Collado on 2010-06-22
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
High
Marc Tardif

Bug Description

udevadm isn't found if "/sbin" isn't in PATH.

The following traceback can be found in log file in such a case:
ERROR Error running event handler None.MessageInfo.message_file() for event type 'message-file' with args (<StringIO.StringIO instance at 0x1906ef0>,) {}.
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/checkbox/reactor.py", line 70, in fire
    results.append(handler(*args, **kwargs))
  File "/usr/share/checkbox/plugins/message_info.py", line 76, in message_file
    messages = template.load_file(file, filename)
  File "/usr/lib/python2.6/dist-packages/checkbox/lib/template_i18n.py", line 131, in load_file
    elements = super(TemplateI18n, self).load_file(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/checkbox/lib/template.py", line 132, in load_file
    % (filename, line)
Exception: Template <stream> parse error at: /bin/sh: udevadm: not found

Related branches

Changed in checkbox:
assignee: nobody → Javier Collado (javier.collado)
status: New → In Progress
Javier Collado (javier.collado) wrote :

Marking bug as 'Opinion' (I cannot mark it as 'Won't fix') since the conditions under the problem happened are unknown.

Changed in checkbox:
status: In Progress → Opinion
Marc Tardif (cr3) wrote :

Jeremy Bicha reported the same problem so I'm reopening this bug. Since the problem seems to be related to the PATH environment variable not including /sbin, and perhaps /usr/sbin even, I'm proposing a fix to actually include those paths in the environment instead of tracking down each command that happens to be under those paths.

Changed in checkbox:
status: Opinion → Confirmed
assignee: Javier Collado (javier.collado) → Marc Tardif (cr3)
importance: Undecided → High
Ara Pulido (ara) wrote :

This was released on checkbox 0.12.4

Changed in checkbox:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers