checkbox-gtk starts mid browser instead of preferred firefox on UNR

Bug #563050 reported by Marc Tardif on 2010-04-14
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
Undecided
Marc Tardif
checkbox (Ubuntu)
Undecided
Marc Tardif
Lucid
Undecided
Unassigned

Bug Description

The impact of this bug is that checkbox behaves differently on Ubuntu and UNR when comes the time to view the report in a browser. This fix simply makes the behavior consistent by checking for gconfd-2 in addition to the gnome-panel.

When running checkbox-gtk on UNR, the summary report seems to appear in the mid browser instead of the preferred firefox browser.

Related branches

Marc Tardif (cr3) wrote :

The reason for this problem is that gconfd-2 runs on UNR instead of gnome-panel. So, the logic in the show_url method of the user interface module should also look for the gconfd-2 process in order to behave in the gnome way.

Marc Tardif (cr3) on 2010-04-14
Changed in checkbox:
assignee: nobody → Marc Tardif (cr3)
Marc Tardif (cr3) on 2010-04-14
Changed in checkbox:
status: New → Fix Committed
Marc Tardif (cr3) on 2010-06-10
Changed in checkbox:
status: Fix Committed → Fix Released
Marc Tardif (cr3) on 2010-06-10
Changed in checkbox (Ubuntu):
status: New → Fix Released
Changed in checkbox (Ubuntu Lucid):
status: New → In Progress
milestone: none → lucid-updates
Changed in checkbox (Ubuntu):
assignee: nobody → Marc Tardif (cr3)
Marc Tardif (cr3) on 2010-06-10
description: updated
Daniel Manrique (roadmr) wrote :

Hello, the following information should complete this bug as a valid SRU report, to hopefully upload this fix to Lucid.

Solution:
Checkbox revision 788 does checking for gconfd-2 in addition to the gnome-panel, to determine whether it can use gconftool to get user preferences. So it will use gconftool to fetch the preferred browser if the system is running either gnome-panel (desktop) or gconfd-2 (UNR). Note that a desktop system runs gconfd-2 BUT a UNR system will NOT be running gnome-panel. However, either one has support for gconftool.

TEST CASE:

This is a bit awkward to confirm as it can possibly interact with bug 562580 in ways that make it unclear which fix is at work.

1- Perform fresh install of UNR 10.04
2- Install chromium-browser or midori
3- Set chromium or midori as the default browser in System -> preferred applications.
4- Apply the code changes for bug 562580, to use Popen.wait() to get the gnome preferred browser.
5- Launch system testing.
6- Do a test run (deselect all tests in the selection screen).
7- Click on "View report" in the summary screen.

The report will open in Firefox instead of the preferred browser (chromium or midori) confirming that the user preference wasn't honored.

Since the fix for bug 562580 was applied, we can be certain that this problem is caused by something else.

Applying the proposed fix makes the report open in the preferred browser (chrome or midori).

Regression potential:
The code just changes a pgrep regular expression to search for gnome-panel or gconfd-2. Thus the only chance of a regression from this would be a situation where the user's preference not being honored *was* the desired behavior, such as an invalid or broken browser being configured, but such an scenario is extremely unlikely. The call to pgrep itself is unlikely to fail or produce unwanted behavior.

Ara Pulido (ara) wrote :

This bug is awaiting verification that the checkbox version in lucid-proposed solves the problem. Please test checkbox and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed
Chris Halse Rogers (raof) wrote :

ubuntu-sru approved and reviewed. Please accept into lucid-proposed.

Hello Marc, or anyone else affected,

Accepted checkbox into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in checkbox (Ubuntu Lucid):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.9.2

---------------
checkbox (0.9.2) lucid-proposed; urgency=low

  New upstream release (LP: #567568):
  * Added referer when sending submissions to Launchpad (LP: #550973)
  * Added suggests to checkbox package in debian/control file (LP: #352740)
  * Fixed udev_resource script to be more resilient (LP: #556824)
  * Fixed cdimage_resource script to read casper.log (LP: #558728)
  * Fixed reporting all resources found for a job (LP: #560948)
  * Fixed stalling when using kdesudo to start backend (LP: #557443)
  * Fixed starting the appropriate default browser on UNR (LP: #563050)
  * Fixed opening the report with the gconf preferred browser (LP: #562580)
  * Fixed suspend_test to use relative time for wakealarm (LP: #349768)
  * Fixed backend not getting terminated upon closing (LP: #553328)
 -- Daniel Manrique <email address hidden> Wed, 22 Jun 2011 14:18:08 -0400

Changed in checkbox (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers