Backend does not get terminated

Bug #553328 reported by Marc Tardif on 2010-04-01
404
This bug affects 111 people
Affects Status Importance Assigned to Milestone
Checkbox
Undecided
Marc Tardif
checkbox (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

The impact of this bug is that when checkbox finished, the backend keeps running forever while consuming processing power the whole time. This fix simply makes sure that the backend finishes when the frontend finishes too.

When Checkbox is stopped, the backend_info plugin sends a kill signal to the backend process. However, since this process is running as root, then the Checkbox process is not allowed to send it a signal.

Related branches

Marc Tardif (cr3) on 2010-04-08
Changed in checkbox:
assignee: nobody → Marc Tardif (cr3)
status: New → Confirmed
Marc Tardif (cr3) on 2010-04-20
Changed in checkbox:
status: Confirmed → In Progress
status: In Progress → Fix Committed
techmin (info-techemia) wrote :

Fix is Committed on 2010/04/20
but a this moment: 2010/04/29
the problem of 100% cpu usage (process backend) is present on ubuntu 10.04 STABLE.

growingneeds (growingneeds) wrote :

I can confirm that this bug exists on my Core2Duo setup. Backend loads 1 core at 100% after System Testing. The process had to be manually killed. This is for the 10.04 Official Stable release.

I did the system testing thing like 5 hours ago, and just noticed "backend" taking 100% cpu too. Fully up to date Lucid on amd64, though I don't know the schedule for releasing a fix after it's been committed.

Pete Gillin (pete-void) wrote :

I am seeing this on up to date 10.04 LTS, '2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:09:38 UTC 2010 x86_64 GNU/Linux'.

Is the advice (until the fix lands) to sudo kill the backend process?

Marc Tardif (cr3) wrote :

Yes, the workaround for now is to sudo kill the backend process unfortunately.

Brian Sell (sellbrian) wrote :

I can confirm this after system testing. Backend running one core @ 100%. Opened system monitor as root [gksudo gnome-system-monitor] to kill backend.

Patrick Hartman (patrickh) wrote :

I am also seeing this on a fresh install of 10.04 x64, had two instances of backend that were using 100% cpu. I was able to do the sudo kill workaround to stop them.

Laurentiu (dvlaur) wrote :

I use, ubuntu 10.4 LTS stable i386, CPU Amd Athlon x2 64, and ai have problems with Backend.
Look at this screen: http://www.shareimage.ro/images/lm9ny85wlq752f8w804.png

jice (jice46) wrote :

I use Ubuntu 10.04 on 2 netbooks - fresh install : aspire one A110 (SSD) and dell mini 9 (SSD). At the same time (about 3h00 paris time) mai 9 2010 my 2 PC's use 100% of one CPU - not always the same cpu, it changes,. The culprit: backend. Not many use of ram:190 Mo (no many programs running except System monitor and Firefox).

Half an hour it runs... it doesn't stop.
I had not this issue with Karmic on my PC's

jice (jice46) wrote :

I add: on each PC no traffic on tthe wifi network

jice (jice46) wrote :

I add also: after reboot all is fine (on the 2 PC's) - Sorry for 3 posts, hope it helps.

Cor Driehuis (cor3huis) on 2010-05-17
Changed in checkbox:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
touristguy87 (touristguy87) wrote :

...guess what I just had to do, guys.

Not only that but it seems that my ISP, Comcast, locked me out of their proxy server cache in the meantime.

took about an hour for that to all straighten up.

backend is stopped for the time-being.

touristguy87 (touristguy87) wrote :

ps who was the moron who decided to move the control boxes to the left side of the window?

please have him taken out and shot, his carcass rent into tiny bits and fed to the squirrels

Brunod (delsupexhe) wrote :

Hi,
Still the same on a laptop with lucid lts after updating all on a fresh install.
BD

meral (meral) wrote :

shit, I found out that process "backend" consumed 100% after I got suspicious of my TOTALLY overheated CPU....

I am under updated lucid on a dual core X301 lenovo laptop.

Sorry I'm a newbie to launchpad.

I have exactly the same issue. I see that this is tagged as "Fix Committed", but where can I get the fix?

222039 (222039-hush) wrote :

Same problem here on intel dualcore, starts after running a system test. Reboot 'fixes' it.

2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:27:30 UTC 2010 i686 GNU/Linux

Tapani Rantakokko (trantako) wrote :

Same problem here with AMD Athlon after running system test. "Fixed" by manually killing the process named 'backend'.

Marc Tardif (cr3) on 2010-06-10
Changed in checkbox:
status: Fix Committed → Fix Released
Marc Tardif (cr3) on 2010-06-10
Changed in checkbox (Ubuntu):
status: New → Fix Released
Changed in checkbox (Ubuntu Lucid):
status: New → In Progress
milestone: none → lucid-updates
Changed in checkbox (Ubuntu):
assignee: nobody → Marc Tardif (cr3)
Marc Tardif (cr3) on 2010-06-10
description: updated

Same problem after test, backend 99%. After sudo kill it back to normal.

$ ps -e -F w -T | grep backend
root 6567 6567 1 92 2044 4460 3 14:54 ? Rs 108:00 /usr/bin/python /usr/share/checkbox/backend /tmp/checkboxAAgvr7/input /tmp/checkboxAAgvr7/output
1000 7389 7389 7358 0 835 932 1 16:51 pts/1 S+ 0:00 grep --color=auto backend

100% usage in sigle cpu, not accessing any file or thread

Demosthenes (demosthenes) wrote :

Fresh install of Lucid on desktop PC here, same issue, killing backend. Frustrating! I thought Ubuntu was ready for the mainstream by now.

Jim J (morlockhq) wrote :

I can confirm the same bug on my Lucid 10.04 install.

One additional detail, if I click through to see the tests that are about to run, but choose not to run the tests by clicking the Next button and instead close the System Tests at that point (after it has gathered system information, but before the tests are run), the backend process launches and still exhibits this behavior.

I've verified that 0.9.2 fixes the 100 CPU issue. (for those who can't wait the merge into lucid, use the ppa:cr3/ppa repository)

But I wonder if the fix isn't just a workaround of a gksu problem. Because ggksu doesn't seem to handle signals properly. I.e. killing the gksu process doesn't kill the children. For example If I do this:

mkdir -p /tmp/checkboxMsblJo
touch /tmp/checkboxMsblJo/input
touch /tmp/checkboxMsblJo/output
gksu -k -- PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games /usr/share/checkbox/backend /tmp/checkboxMsblJo/input /tmp/checkboxMsblJo/output

and kill the gksu process (e.g. CTRL-C), I will still have a 100% CPU process running. So the fix works, but only because it destroys the pipe that backend is waiting on.

Should a bug be opened against gksu ?

Aris Manginas (babis-sealabs) wrote :

Problem still remains (started when upgraded 10.04). :(
Sudo killing the process still leaves the system monitor applet with at least 60% cpu usage, though the processes shown in htop (or top) dont stack up to this percentage... No reboots fix the issue either.

$ ps -eo pcpu,args|sort -rn|head
81.2 /usr/bin/python /usr/share/checkbox/backend /tmp/checkboxcHjiFY/input /tmp/checkboxcHjiFY/output
10.0 /usr/bin/X :0 -nr -verbose -auth /var/run/gdm/auth-for-gdm-EdfrCB/database -nolisten tcp vt7
 9.0 /usr/lib/libgconf2-4/gconfd-2
 4.8 /bin/dbus-daemon --fork --print-pid 5 --print-address 9 --session
 3.7 /opt/google/chrome/chrome --type=renderer --lang=el --force-fieldtest=CacheSize/CacheSizeGroup_3/DnsImpact/_max_2 concurrent_prefetch/GlobalSdch/_global_enable_sdch/ --channel=5101.0x481aa40.291792407
 2.6 gnome-session
 2.0 evolution
 2.0 compiz --replace
 1.6 gnome-panel
 1.5 python /usr/share/system-config-printer/applet.py

$uname -a
Linux ubuntu 2.6.32-23-generic #37-Ubuntu SMP Fri Jun 11 08:03:28 UTC 2010 x86_64 GNU/Linux

$lscpu
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
CPU(s): 2
Thread(s) per core: 1
Core(s) per socket: 2
CPU socket(s): 1
NUMA node(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 15
Stepping: 11
CPU MHz: 2666.902
Virtualization: VT-x
L1d cache: 32K
L1i cache: 32K
L2 cache: 4096K

Nixloz (nixloz) wrote :

I only opened the system testing app, but never really started it.
the backend continued after closing the app though, causing one of the 2 cores to be at 100% all of the time (occasionally switching core).

Issy (w1pa) wrote :

Just fresh installed 10.04 LTS today...same as Nixloz. Went into System Testing twice, Networking only, to see what my wireless card was on my X31, and exited out without completing the test. Found after 5 minutes the fan was running continuous, and "top" showed two "backend" processes consuming 100% cpu. Manually killed both.

Peter B P (peterbp) wrote :

Bug is still extant in 10.04 with latest updates, incl. ubuntu-proposed.

Guys, read the statuses abroad and the comments

* bug is fixed in upstream
* fixed in developer branch
* not yet merged in lucid due to a pending review:
** https://code.launchpad.net/~cr3/ubuntu/lucid/checkbox/0.9.2/+merge/28341
* you can use the ppa:cr3/ppa repository if you can't wait for the fix to be merged.

Benjamin Drung (bdrung) wrote :

unsubscribing ubuntu-sponsors. Please resubscribe the team once Mathias' concerns are addressed.

Changed in checkbox (Ubuntu Lucid):
assignee: nobody → Benjamin Drung (bdrung)
assignee: Benjamin Drung (bdrung) → nobody
assignee: nobody → Benjamin Drung (bdrung)
assignee: Benjamin Drung (bdrung) → nobody
Dan Becker (beckerz) wrote :

Same issue, system up to date as of today. Started in core1 then core 2 and stayed in core 3 until I killed it. I was looking for system monitor and started system testing by mistake.

edgar@olg.com (edgar-olg) wrote :

Me too, me too, and after a while the fan starts to blow because I guess the CPU is overheating.
 But here is the real weird thing - when all this is happening, it is the only time my hsf modem connects properly.

Alexis Wilke (alexis-m2osw) wrote :

I just ran in this problem. Same problem: 100% of one of the CPUs used. I could just kill the process and got everything back to normal.

hawthornso23 (hawthorn) wrote :

A fix was apparently committed in June of last year. Lucid still has the problem. What happened to the `pending review' that was supposed to happen in August. Does somebody need a gentle reminder - a.k.a. - kick in the pants.

This is a pretty serious problem potentially shortening the life of hardware. Anyone who runs system testing will have a CPU running at 100% from then on. Many people may not realise this is happening. Even logging out and back in won't stop it. Only a reboot will kill the process and there are lots of people (like me) who go for weeks or even months at a time without rebooting.

Running a CPU at 100% for that length of time is a pretty harsh thing to do to hardware.

I don't know when the fix will get to the Lucid repositories. However, in the meantime, I've uploaded a package to checkbox-developers PPA:
https://launchpad.net/~checkbox-dev/+archive/ppa

The package contains the latest version of the code so it has not only the fix you are looking for, but also all the fixes that have been submitted after that one.

hawthornso23 (hawthorn) wrote :

Thanks for that Javier. I appreciate your effort. The checkbox developers have done all that can be expected of them by fixing the bug promptly. It is the Lucid package maintainers who seem to have dropped the ball.

hawthornso23 (hawthorn) wrote :

Would changing the importance of this bug from undecided to high help make it more visible to the lucid packagers?

Rogerio Dias (rogdias) wrote :

I've found this backend process running at almost 100% in my Linux roger-eeepc 2.6.32-27-generic #49-Ubuntu SMP Wed Dec 1 23:52:12 UTC 2010 i686 GNU/Linux
I only became aware of this because the computer was too slow.
Is there a way to set an alert when this 100% cpu usage happens?
I'm not quite versed in Linux (but adopted it and I'm satisfied with it).
Cheers from Rio.

AdamOutler (adamoutler) wrote :

I'm having this problem as of late. It's taking up 101%... I have 400% available. I have one core being continuously taxed by Ubuntu One..... The one piece of non-free software I have on my computer and it is hogging up processor. Canonical, fix your shit. This is rediculous. One problem after another with Ubuntu One.. I want it gone.

Nilesh (lvnilesh) wrote :

Installed Ubuntu 10.04.2 LTS GNU/Linux x86_64 2.6.32-28-server #55-Ubuntu SMP Mon Jan 10 23:57:16 UTC 2011.
Went through System Testing and exited after completing the test. Found after 5 minutes the fan was running continuous, and "top" showed one "backend" processes consuming 100% cpu. Manually killed "backend" to achieve world peace!

Silviu C. (silviucc) wrote :

Still happening on Ubuntu 10.04 LTS 2.6.32-29-generic-pae #58-Ubuntu. I started the System Testing program, checked what tests it would perform and then closed it without performing any tests. I did not notice any system slowdowns but noticed when I started system monitor that I had one core @ 100% usage.

Started top and there it was "backend" doing nothing but eating CPU cycles. Had to killall it. Guys, please, pretty please with cherries and sprinkles on top, fix it :)

Ara Pulido (ara) on 2011-03-09
Changed in checkbox (Ubuntu Lucid):
status: In Progress → Fix Committed
status: Fix Committed → In Progress

@Silviu

As a workaround, please see #34 to get an update from the checkbox-developers PPA with the fix.

Changed in checkbox (Ubuntu):
assignee: Marc Tardif (cr3) → Vistavnoy Roman Valentinovich (rvystavnoy)
assignee: Vistavnoy Roman Valentinovich (rvystavnoy) → nobody
Kangarooo Jānis (kangarooo) wrote :

Clean new Ubuntu 10.04.2 & latest updates. still exists

Daniel Manrique (roadmr) wrote :

Hello, the following information should complete this bug as a valid SRU report, to hopefully upload this fix to Lucid.

Solution:

Checkbox revision 796 addresses this by Closing fifo descriptors so that backend can get terminated.

TEST CASE:
1- Perform a fresh installation of 10.04 and do a dist-upgrade to install checkbox 0.9.1.

2- Launch System Testing and press "Next".

3- Input the user password when prompted, wait for System Testing to finish "gathering information from your system".

4- Close the System Testing application.

5- A process /usr/bin/python /usr/share/checkbox/backend remains. This process's CPU usage starts climbing up eventually reaching 100%.

Regression potential:
The fix makes the code more robust and closes descriptors, basically just required cleanup, so there's almost no potential for a regression.

Ara Pulido (ara) wrote :

This bug is awaiting verification that the checkbox version in lucid-proposed solves the problem. Please test checkbox and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed

Hello Marc, or anyone else affected,

Accepted checkbox into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in checkbox (Ubuntu Lucid):
status: In Progress → Fix Committed
Chad A. Davis (chadadavis) wrote :

Verified fix from checkbox 0.9.2 on Lucid

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.9.2

---------------
checkbox (0.9.2) lucid-proposed; urgency=low

  New upstream release (LP: #567568):
  * Added referer when sending submissions to Launchpad (LP: #550973)
  * Added suggests to checkbox package in debian/control file (LP: #352740)
  * Fixed udev_resource script to be more resilient (LP: #556824)
  * Fixed cdimage_resource script to read casper.log (LP: #558728)
  * Fixed reporting all resources found for a job (LP: #560948)
  * Fixed stalling when using kdesudo to start backend (LP: #557443)
  * Fixed starting the appropriate default browser on UNR (LP: #563050)
  * Fixed opening the report with the gconf preferred browser (LP: #562580)
  * Fixed suspend_test to use relative time for wakealarm (LP: #349768)
  * Fixed backend not getting terminated upon closing (LP: #553328)
 -- Daniel Manrique <email address hidden> Wed, 22 Jun 2011 14:18:08 -0400

Changed in checkbox (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers