Checkbox doesn't eval any requirements when a registry fails

Bug #457502 reported by Marc Tardif on 2009-10-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
Critical
Marc Tardif

Bug Description

When Checkbox attempts to eval requirements, it uses the registry to interpret variable names. However, if a command registry fails, the following traceback might be generated:

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/checkbox/reactor.py", line 89, in fire
    results.append(handler(*args, **kwargs))
  File "/usr/share/checkbox/plugins/registry_info.py", line 31, in gather
    registry_eval_recursive(self._manager.registry, "False")
  File "/usr/lib/python2.6/dist-packages/checkbox/registry.py", line 180, in registry_eval_recursive
    values.extend(registry_eval_recursive(value, source, mask))
  File "/usr/lib/python2.6/dist-packages/checkbox/registry.py", line 180, in registry_eval_recursive
    values.extend(registry_eval_recursive(value, source, mask))
  File "/usr/lib/python2.6/dist-packages/checkbox/registry.py", line 178, in registry_eval_recursive
    for key, value in registry.items():
  File "/usr/share/checkbox/registries/gconf.py", line 43, in items
    lines[-1] += line
IndexError: list index out of range

The problem is that the status of running a command registry is not checked. So, in the event the gconftool-2 command is not found in the above gconf registry example, then the string "Command not fond" is returned and then parsed. Instead, the status of the command should be checked.

Related branches

Marc Tardif (cr3) on 2009-10-21
Changed in checkbox:
assignee: nobody → Marc Tardif (cr3)
importance: Undecided → Critical
status: New → In Progress
Marc Tardif (cr3) on 2009-10-21
Changed in checkbox:
status: In Progress → Fix Committed
Marc Tardif (cr3) on 2009-10-30
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers