Checkbox tests using gksudo return empty output

Bug #425284 reported by Marc Tardif on 2009-09-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
Medium
Marc Tardif

Bug Description

Some Checkbox tests currently use gksudo to workaround the bug where tests cannot be run by the backend as root. The problem is that gksudo does not seem to preserve the PATH environment variable even if passed the -k option. So, all the tests using gksudo return empty output because the command itself is not being found.

Related branches

Marc Tardif (cr3) wrote :

The solution for now is to simply specify the absolute path to the script instead of relying on the PATH environment variable.

Changed in checkbox:
assignee: nobody → Marc Tardif (cr3)
importance: Undecided → Medium
milestone: none → 0.8-alpha6
status: New → Fix Committed
Marc Tardif (cr3) on 2009-10-14
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers