Checkbox should support an alias for the linux kernel package

Bug #423805 reported by Marc Tardif on 2009-09-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
Medium
Marc Tardif

Bug Description

When reporting bugs with apport, Checkbox can use the requires field in a test to determine the relevant package for the test. The problem is that there is no way for a requires expression to isolate the package corresponding to the currently running kernel. So, the package registry should support the concept of aliases so that a requires expression could be defined as: package.alias == 'linux'.

Related branches

Marc Tardif (cr3) on 2009-09-03
Changed in checkbox:
assignee: nobody → Marc Tardif (cr3)
importance: Undecided → Medium
milestone: none → 0.8-alpha6
status: New → Fix Committed
Marc Tardif (cr3) on 2009-10-14
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers