Multiple results when navigating back/forward

Bug #396063 reported by Javier Collado on 2009-07-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
High
Marc Tardif

Bug Description

When running a test suite, if previous/next buttons are pressed to review some results, they will be added again to the report so multiple results will be reported for the same test case.

Procedure to reproduce the problem:
- Use attached test suite (containing just test-1 and test-2)
- When test-1 is displayed press next
- When test-2 is displayed press previous
- Press next twice
- Press view report
- Report will be displayed with 4 different results (two for each test case)

David Murphy (schwuk) wrote :

Able to reproduce in stock checkbox (jaunty).

Changed in checkbox:
status: New → Confirmed
David Murphy (schwuk) wrote :

Triaged. Setting this bug as high since there is the potential for results to skewed by this bug.

Changed in checkbox:
assignee: nobody → Marc Tardif (cr3)
importance: Undecided → High
milestone: none → 0.8-alpha3
status: Confirmed → Triaged
Marc Tardif (cr3) on 2009-07-23
Changed in checkbox:
status: Triaged → Fix Committed
Marc Tardif (cr3) on 2009-08-25
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers