Output not captured in shell plugin when command fails

Bug #393894 reported by Javier Collado on 2009-06-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
Medium
Marc Tardif

Bug Description

When using the shell plugin, it has been found that the output of the command is captured and stored in the logs if the test was successful. However, if the command fails, its output isn't displayed in the report, which makes difficult to find out why it failed since the error messages that it might have printed to stdout are missing.

Please find attached a test suite and a script example to reproduce the problem.

Related branches

David Murphy (schwuk) on 2009-07-06
Changed in checkbox:
importance: Undecided → Medium
milestone: none → 0.8-featurefreeze
status: New → Triaged
Marc Tardif (cr3) on 2009-08-31
Changed in checkbox:
assignee: nobody → Marc Tardif (cr3)
status: Triaged → In Progress
status: In Progress → Fix Committed
Marc Tardif (cr3) on 2009-10-14
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers