Collect information from /etc/sysctl*

Bug #331055 reported by David Murphy on 2009-02-18
10
Affects Status Importance Assigned to Milestone
Checkbox
High
David Murphy
Launchpad itself
High
Unassigned

Bug Description

Information should be collected from /etc/sysctl* and passed to Launchpad by default.

David Murphy (schwuk) on 2009-02-18
Changed in checkbox:
importance: Undecided → High
status: New → Confirmed
Abel Deuring (adeuring) on 2009-02-19
Changed in malone:
importance: Undecided → High
status: New → Triaged
David Murphy (schwuk) wrote :

Commited in trunk r493.

Changed in checkbox:
assignee: nobody → schwuk
status: Confirmed → Fix Committed
Marc Tardif (cr3) wrote :

This was generating errors when run on Hardy because the sysctl.d directory doesn't exist. So, the code has been changed slightly to look for sysctl.*, as initially requested. It then creates a FileRegistry for sysctl.conf if found and a RecursiveDirectoryRegistry for sysctl.d if found.

David Murphy (schwuk) wrote :

Released with Checkbox 0.7

Changed in checkbox:
status: Fix Committed → Fix Released
Robert Collins (lifeless) wrote :

What remains in LP for this to be fix released?

Changed in launchpad:
status: Triaged → Incomplete
Marc Tardif (cr3) wrote :

Dave, might it be possible that this bug was marked as affecting Launchpad because the information could potentially be structured? Since info elements in the submission.xml seem to work fine, perhaps we could mark this bug as invalid for Launchpad.

Curtis Hovey (sinzui) on 2012-09-12
Changed in launchpad:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers