Configuration file `/etc/checkbox.d/checkbox.ini' changed (prompts for install/keep/diff even though I never changed checkbox.ini)

Bug #330596 reported by Sean Sosik-Hamor on 2009-02-17
86
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Checkbox
High
Marc Tardif
checkbox (Ubuntu)
Medium
David Murphy
Jaunty
Medium
David Murphy

Bug Description

sciri@baka:~$ lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:cxx-3.0-amd64:cxx-3.0-noarch:cxx-3.1-amd64:cxx-3.1-noarch:cxx-3.2-amd64:cxx-3.2-noarch:desktop-3.1-amd64:desktop-3.1-noarch:desktop-3.2-amd64:desktop-3.2-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.0-amd64:graphics-3.0-noarch:graphics-3.1-amd64:graphics-3.1-noarch:graphics-3.2-amd64:graphics-3.2-noarch:qt4-3.1-amd64:qt4-3.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu jaunty (development branch)
Release: 9.04
Codename: jaunty

When upgrading from checkbox 0.4 to checkbox 0.5 (Jaunty) I am prompted to install/keep/diff checkbox.ini even though I never made changes to that file.

Setting up checkbox (0.5) ...
*** WARNING: ucf was run from a maintainer script that uses debconf, but
             the script did not pass --debconf-ok to ucf. The maintainer
             script should be fixed to not stop debconf before calling ucf,
             and pass it this parameter. For now, ucf will revert to using
             old-style, non-debconf prompting. Ugh!

             Please inform the package maintainer about this problem.
Configuration file `/etc/checkbox.d/checkbox.ini'
 ==> File on system created by you or by a script.
 ==> File also in package provided by package maintainer.
   What would you like to do about it ? Your options are:
    Y or I : install the package maintainer's version
    N or O : keep your currently-installed version
      D : show the differences between the versions
      S : show the side-by-side differences between the versions
      Z : start a new shell to examine the situation
 The default action is to keep your current version.
*** checkbox.ini (Y/I/N/O/D/Z) [default=N] ?

Sean Sosik-Hamor (sciri) wrote :

Also effects checkbox-gtk.

Setting up checkbox-gtk (0.5) ...
*** WARNING: ucf was run from a maintainer script that uses debconf, but
             the script did not pass --debconf-ok to ucf. The maintainer
             script should be fixed to not stop debconf before calling ucf,
             and pass it this parameter. For now, ucf will revert to using
             old-style, non-debconf prompting. Ugh!

             Please inform the package maintainer about this problem.
Configuration file `/etc/checkbox.d/checkbox-gtk.ini'
 ==> File on system created by you or by a script.
 ==> File also in package provided by package maintainer.
   What would you like to do about it ? Your options are:
    Y or I : install the package maintainer's version
    N or O : keep your currently-installed version
      D : show the differences between the versions
      S : show the side-by-side differences between the versions
      Z : start a new shell to examine the situation
 The default action is to keep your current version.
*** checkbox-gtk.ini (Y/I/N/O/D/Z) [default=N] ?

Steve Langasek (vorlon) wrote :

Confirmed here. Here is the diff between the old and new versions of the file:

$ diff -u /etc/checkbox.d/checkbox-gtk.ini*
--- /etc/checkbox.d/checkbox-gtk.ini 2009-01-25 12:22:46.000000000 -0800
+++ /etc/checkbox.d/checkbox-gtk.ini.ucf-dist 2009-02-17 10:47:27.000000000 -0800
@@ -2,8 +2,9 @@
 includes = %(checkbox_share)s/configs/checkbox.ini

 [checkbox/plugins/user_interface]
-gtk_path = %(checkbox_share)s/gtk
-interface_class = GTKInterface
 interface_module = checkbox_gtk.gtk_interface
 title = System Testing
+data_path = %(checkbox_share)s/gtk
+gtk_path = %(checkbox_share)s/gtk
+interface_class = GTKInterface

This suggests that ucf is being used wrong. Why is this even a config file at all, let alone a ucf-managed config file instead of a conffile? While it's possible that the config file won't change again prior to the jaunty release, it's important to address the root of this bug prior to release so that the prompt doesn't recur on upgrades from jaunty to jaunty+1.

Changed in checkbox:
importance: Undecided → Medium
status: New → Triaged
Steve Langasek (vorlon) on 2009-02-17
Changed in checkbox:
assignee: nobody → cr3
Max Bowsher (maxb) wrote :

/usr/share/checkbox/install/postinst (sourced from the actual postinst) contains the following incorrect ucf usage:

        [ -e "$config" ] && ucf $tempfile $config || cp $tempfile $config

resulting in the file not being registered with ucf on initial installation.

David Baucum (maxolasersquad) wrote :

I got the same thing here. Installed Jaunty Alpha 4 from CD and immediately installed updates and got this.

I have the exact same problem here. After rebooting from the upgrade process, System Testing application will not run. It will crash after enter your password.

David Murphy (schwuk) wrote :

This problem should have been addressed in Checkbox 0.7 that is now in Jaunty. Please can you all retest?

David Murphy (schwuk) wrote :

There's been another occurrence of this with 0.7, so it may not be resolved yet.

Changed in checkbox:
assignee: nobody → cr3
importance: Undecided → High
milestone: none → 0.7.1
status: New → Confirmed
Jorge Castro (jorge) wrote :

I just did an alpha6->jaunty-as-of-right-now upgrade and I still see this, version is .7

orngreen (orngreen) wrote :

checkbox.ini:
  The Diff shows the added "blacklist = backend_manager" in the [Checkbox/plugins] section
checkbox-gtk.ini:
  The "data_path = %(checkbox_share)s/gtk" has been moved up, two lines :)

I'm positive I haven't touched either file, so it shouldn't really nag me with this.

Marc Tardif (cr3) wrote :

Thanks for the feedback everyone, I have just committed a fix which basically removes ucf from the equation because there is currently no use case which would warrant a user to modify their own configuration file.

Changed in checkbox:
status: Confirmed → Fix Committed
Changed in checkbox (Ubuntu Jaunty):
status: Triaged → Fix Committed
Max Bowsher (maxb) wrote :

@Marc

Does this mean the file is silently overwritten on package upgrades? That would be very unfriendly, and contravene the Policy Manual.

David Murphy (schwuk) wrote :

Released in Checkbox 0.7.1.

Changed in checkbox:
status: Fix Committed → Fix Released
Changed in checkbox (Ubuntu Jaunty):
status: Fix Committed → Fix Released
David Murphy (schwuk) wrote :

Prematurely set to Fix Released for Jaunty - waiting for package to be uploaded.

Changed in checkbox (Ubuntu Jaunty):
assignee: cr3 → schwuk
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.7.1

---------------
checkbox (0.7.1) jaunty; urgency=low

  * New Bugfix release (LP: #352389)
  * New icon
  * Fixed pygst dependency (LP: #334442)
  * Fixed configuration file updates during install (LP: #330596) and
    and DBus exceptions (LP: #344916)
  * Expanded and fixed translations (LP: #347038)

 -- Dave Murphy <email address hidden> Tue, 31 Mar 2009 13:54:12 +0100

Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers